New installation hangs


Downloaded the latest distro (32 Bit Stable-5.211.65-13, Release Date-06-03-14) and burned it to a DVD. Tried installing it many times, but always hangs at the installation of at module 425 (PBX web interface).

Tried with Asterisk 1.8 and 11 - both the same.

Using a static IP and I can ping the box.

Have used the same box for testing a few months back with no problems (Older version).

I did have an old CD here and just threw that in (32 Bit Stable 4.221.64-7) and tried that without any problems at all.

Any ideas?



Looks like you’re experiencing what I experienced yet.

Read the full whole story here (it’s a bit long and I initially started it because I doubted about my DVD burning and/or ISO downloads quality…).

At the end I was able to install but I didn’t really found why my very latest attempt was so successful in comparison to all my previous ones…

parnassus I read your whole story before I posted, but as you had a hang-up at a different point and there was no solution at all, I decided to post anyway.

I am willing to test - if I know what I should test :wink:

Yes, exactly. You’re right to post your experience.

In my specific case the FreePBX Distro installation phase hanged only and always once arrived at sysadmin RPM package install time (which is the 425th RPM - 73% - package on latest FreePBX Distro).

During the freepbx RPM package install instead it just slowed down (due to repetitive errors that, at some point, end…errors that are visible during the install procedure on console F9 if I recall well).

FreePBX RPM takes along time to install as it has to also install and enable 60 modules. Its a 15-20 minute process.

I have a problem with my central telephone extension cords do not want to show or tell the message of the voice mail. “please leave message after tone” to caller "I have configured all the ways that I saw but never works with any of extensions can help me to see how active this message.

I want each user to have their voicemail but this does not set or should I just change the MV which is your answer have a IPBBX Trixbox.

Tony, I agree with you but only if we consider that the install process could halt (or looks halted) for half an hour or so…then the Internet access speed could be the point at looking for…but, even if I consider the worst case (very slow?) of download/upload speed at my location from/to your FreePBX mirrors (a thing that proved to be not the usual case - I tested during different day time in different days - while I manually downloaded an RPM file just to test the correctness of my Internet connectivity to FreePBX mirrors), then I can’t reasonably expect (or justify) many hours (or an whole night) to download what is needed by sysadmin module.

Just to make a comparison: the ISO’s 1 Gigabytes itself would have taken weeks to download each time, which was not the case, since I downloaded at least 4 different published - but unofficial - ISOs in a few days, if not hours, time window before the latest one went public as FreePBX Distro 5.211.65-13.

Please also consider that the “Internet Access Test” phase prior to the download of various necessary modules never appeared during all install attempts done…so let me state I wasn’t confused by an install process that looked completely halted…it was really halted (no ethernet RX/TX packets traffic, as I wrote).

Tony, I stopped the install after 2 hours. I have Fios and the internet connection works without a problem.

The FreePBX RPM never touches the internet. Only the sysadmin RPM does. The FreePBX RPM installs from the local ISO all the opensource modules.

Exactly, it’s the sysadmin RPM package that halt the install, not the freepbx RPM package (I never wrote that freepbx RPM package halts the install).

Thanks guys for all your messages.

Now, what should I do? What do you want me to test.

Go backwards in versions to see where the change was?

I can’t add nothing useful by now (up to now I wrote just too much) but I can confirm I tried the FreePBX Distro 4.211.64-9 and it halted (unexpectedly) exactly like the latest FreePBX Distro 5.211.65-12/-13…

What is your system configuration (Bare metal or VM)? which type of disk if bare metal (Rotational SATA/PATA or SSD) you’re installing to?

Did you use a DVD or CD for the 4.211?

I used a CD (as I still had this), but a DVD for the 5.211.

This is a real box, no VM. It had been running 4.211 without problems as a test system before. SATA HDD, no SSD.

During my install attempts I always used various DVD-RW (and, every time, I did a fast/complete blanking between each ISO burn).

The funny thing is that just about one years ago, in my same network (so LAN/WAN wasn’t changed apart from that Firewall rule about IGMP), I installed the FreePBX Distro 4.211.64-6 I am still using, upgraded to 5.211.65-12 (I don’t remember if, for that first install, I used a CD-RW or a DVD-RW but, probably, a CD-RW because that ISO was below CD size limit if I recall well).

Is the dmesg OK (no errors/warnings)?

Today I reinstalled (switching back to) FreePBX Distro 5.211.65-12 (not -13!) and the installation this time, while with the presence of the same errors/messages, completed!

But not successfully…

It seems that it doesn’t see Internet Connection during the install phase…indeed it completed.

After the reboot the system, while checking deployment, asked me to execute the /etc/ script in a shell (I exectuted but it still fails).

The FreePBX GUI is responsive (I created a user account “admin”) and using FreePBX Module Admin I downloaded about 56 modules (so Internet is OK), neverthless more are needed.

Internet Connectiviy is SO OK that before creating the user account through FreePBX GUI I did a yum update (freepbx RPM was updated with other packages) and then performed a full reboot (after that reboot the invoked /etc/ script failed once again).

From the FreePBX GUI there are no problem: now I’m trying to update FreePBX Core (2.11.20 to 2.11.30) but it fails because FreePBX Framework module is disabled (and FreePBX ARI Framework too)…I enabled it (it needs to be updated to 2.11.37), I updated and now I’m able to finally update FreePBX Core…jajajaja…now it’s time for FreePBX Sysadmin (, which again was disabled, that need to be updated to…updated…OK…what a journey!

In the end this teach me that Internet Connectivity seems not to be reconized during install (even if Anaconda, this time, completes) and this causes all the extra job of enabling, downloading and updating those module (AFAIK) once into FreePBX GUI.

So through Linux CLI (after the first reboot) and then through the FreePBX GUI there aren’t problems in downloading RPM or FreePBX Modules (FreePBX GUI reports 10MB/26MB transferred through eth0, DHCP enabled).

Every each reboot I do the check deployment message appears asking me to execute the first boot script due to some firsboot errors. The FreePBX Distro is fully updated yet.

This with the FreePBX Distro 5.211.65-12…the same that failed few days ago, installed in the same Hardware using the same specific DVD-RW (media check was OK), into the same SATA HDD Seagate. NO words.

The more I look into the more I’m not able to found a significative meaning…

Interestingly enough I see these PHP Warnings in freepbx.log:

[2014-Jun-10 10:46:07] [PHP-WARNING] (/var/www/html/admin/modules/sysadmin/ - No license for this product (PBXact) - make sure zend_loader.license_path is properly configured in your ini file! [2014-Jun-10 10:46:07] [PHP-WARNING] (/var/www/html/admin/modules/sysadmin/ - License check failed! [2014-Jun-10 10:46:07] [PHP-WARNING] (/var/www/html/admin/modules/sysadmin/ - No license for this product (PBXact) - make sure zend_loader.license_path is properly configured in your ini file! [2014-Jun-10 10:46:07] [PHP-WARNING] (/var/www/html/admin/modules/sysadmin/ - License check failed! [2014-Jun-10 10:46:09] [PHP-WARNING] (/var/www/html/admin/modules/sysadmin/ - No license for this product (PBXact) - make sure zend_loader.license_path is properly configured in your ini file! [2014-Jun-10 10:46:09] [PHP-WARNING] (/var/www/html/admin/modules/sysadmin/ - License check failed! [2014-Jun-10 10:46:23] [PHP-WARNING] (/var/www/html/admin/modules/sysadmin/ - No license for this product (PBXact) - make sure zend_loader.license_path is properly configured in your ini file! [2014-Jun-10 10:46:23] [PHP-WARNING] (/var/www/html/admin/modules/sysadmin/ - License check failed! [2014-Jun-10 10:46:23] [PHP-WARNING] (/var/www/html/admin/modules/sysadmin/ - No license for this product (PBXact) - make sure zend_loader.license_path is properly configured in your ini file! [2014-Jun-10 10:46:23] [PHP-WARNING] (/var/www/html/admin/modules/sysadmin/ - License check failed!

Could those warnings be related to this <a href=>FREEPBX-7031 (closed) ticket?

EPM Pro is not installed. Other Commercial or Unsupported modules aren’t installed. This system wasn’t registered yet (It’s only a test system).