New Distro Version 1.810.210.57-1

We just released an upgrade script for FreePBX Distro Version 1.810.210.57-1. This will upgrade to the latest Asterisk 1.8.10 and Dahdi 2.6

I am working on a Asterisk 10.2 based ISO this week and should have something for early Beta testers late this week. Due to issues we keep seeing with Centos 6.x we will be keeping on Centos 5.7 at this time.

As always please follow for upgrade procedures.

Since I ran the upgrade the Dahdi Module will not load in Asterisk. I get this error

[2012-03-12 19:11:48] WARNING[4609]: loader.c:396 load_dynamic_module: Error loading module ‘’: cannot open shared object file: No such file or directory


What version did you have prior to the upgrade script.

What RPMs of Dahdi do you have installed and of libeopenr

you can do a rpm -qa | grep dahdi than do a rpm -qa | grep libopenr. Paste the output here.

Also is this a 64bit or 32bit

I was running prior to the update and used the update script.

rpm -qa | grep dahdi dahdi-firmware-oct6114-128-1.05.01-29_centos5 dahdi-linux-2.6.0-20_centos5 dahdi-linux-kmod-debuginfo-2.6.0-14_centos5.2.6.18_274.3.1.el5 asterisk18-dahdi- kmod-dahdi-linux-2.6.0-14_centos5.2.6.18_274.3.1.el5 dahdi-firmware-hx8-2.06-29_centos5 dahdi-firmware-oct6114-256-1.05.01-29_centos5 dahdi-firmware-tc400m-MR6.12-29_centos5 dahdi-firmware- dahdi-linux-debuginfo-2.6.0-20_centos5 dahdi-tools-debuginfo-2.6.0-26_centos5 dahdi-tools-doc-2.6.0-26_centos5 dahdi-firmware-vpmoct032-1.12.0-29_centos5 dahdi-firmware-oct6114-064-1.05.01-29_centos5 dahdi-tools-2.6.0-26_centos5 dahdi-linux-devel-2.6.0-20_centos5

When I do a rpm -qa | grep libopenr I get nothing in the output.

Ok and are you using 32bit or 64bit. Also not sure why you do not have libopenr2 as that is required for dahdi and every other version should have it. Do a yum install libopenr2. Than restart asterisk and dahdi and see if that solves your problem. If so I will add it to the script to make sure that is installed. I just assumed it was installed on all previous systems as mine has it

The module loaded now and I am running a 32bit system. I had upgraded this system a few weeks ago from a 1.8.2 following the upgrade scripts.

Thanks for the help.

Ahh yes those old original Beta 1.8.x systems have missing things I have noticed. Those were the original beta releases that we have attempted to take to final. I added a check to make sure it is installed moving forward. Thanks for catching that.

I have just upgraded from to 1.810.210.57-1 and dahdi seems to have disappeared. From the CLI a core show help dahdi says no such command dahdi.

rpm -qa | grep dahdi gives:


rpm -qa | grep libopenr gives:


All dahdi config files are in place and contain the correct data.

Any suggestions please?

Did you try a reboot. Just seems asterisk is not loading dahdi correct.

I did try a reboot which did not get things moving.

Just a few minutes ago I ran /usr/sbin/dahdi_genconf from the command line and dahdi reappeared after I had done this and restarted asterisk.

I then found that my /etc/asterisk/chan_dahdi.conf had been overwritten and my change there to include /etc/asterisk/chan_dahdi_channels_custom.conf had gone. [By the way I hold my pri and SS7 linkset configs in this included custom file].

I reinserted my include, did a dahdi restart and everything appears to be working as it should be.

I have since restarted asterisk and done a reboot and everything comes back normally.

It does seem that asterisk did not load dahdi correctly, however, I have no real idea why my actions resolved the issue.

I am using this system to test SS7 so it was not in production. I will now watch it to see how it performs with the upgrades.

Did you have the dahdi module installed in the GUI. This will always break things if you had it installed.

Yes I did, and yes I have realized that was what broke things. I have now removed the module and everything seems to be OK


I have been doing some link testing with the distant end today and I am finding that inbound my E1 pri channels are badly distorted now I have upgraded to dahdi 2.6.

I have changed out the Digium interface hardware and the problem persists.

I am considering going back to an older version of the distro with the older version of dahdi as I cannot find anything that could be causing this problem.

Before I do this would like to know if anyone has got pri’s working with dahdi 2.6 without problems? Also does anyone have any ideas what might be happening?

I have not tried it with 2.6 yet.

Would be great to know befoe doing something radical!

I went back to Distro version, the problem disappeared and voice quality was normal. I have upgraded as far as and everything remains good. Tomorrow I will continue the exercise to see if something breaks when Dahdi upgrades from to 2.6 and asterisk from 8.9 to 8.10.


What I would do is get to the Asterisk 1.8.9 version. Than test. If no problems go edit the /etc/yum.repos.d/FreePBX.repo file. At the bottom change the yum repo to 1.810.210.57 from the

Than do a yum clean all to get the new repo data.

Than do a yum update asterisk18*. Restart asterisk when done and test. This will get you on Asterisk 1.8.10 but with dahdi 2.5. That way you can pinpoint the problem to Asterisk 1.8.10 or Dahdi 2.6.

After that you can still run the normal upgrade script to go to 1.810.210.57 version.

Does that make sense to you?

The problem you are reporting may be related to this one:

Tony, this is looking more and more like a current installation/upgrade issue.


Makes perfect sense, have gone to asterisk OK and voice quality still good. Now going to run the upgrade script to get dahdi 2.6 as well.