FreePBX | Register | Issues | Wiki | Portal | Support

Need help making FreePBX an actual stable build

bug
Tags: #<Tag:0x00007fcd20d3f708>

(United States) #1

I installed freepbx countless times each ending up with the same results… Followed freepbx install guide to a tee. This is for FreePBXv15 and Asteriskv16 builds. The issues I am having are listed below:

  1. This one is just a huge pain in the a$$ every time I go to sleep at night I wake up to 60 new modules installed everyday and when I know when it happens cause every time I got to login I get this error “0 System Admins” I have to go in and delete ‘/var/www/admin/modules/sysadmin’

  2. I tried submitting a bug tracker report but they say its not a bug even though both Debian and Ubuntu Builds do this. What happens is when I add an outbound route the configuration closes takes me back to the outbound routes it then shows nothing but the Red button that says “Reload Asterisk” appears as if I applied a new rule. This tells me that my outbound route was applied but not visible via the panel!

I can’t really think of anything else at the moment…


(Andrew Nagy) #2
  1. Will have to look at why it’s installing sysadmin on your non commercial system. However you have the setting enabled to automatically upgrade modules. That is why this is happening

  2. There’s already a ticket about this but Debian and Ubuntu are not supported systems. That is why your tickets are being closed


(Tom Ray) #3

If you want a stable build you should be using FreePBX v14 since v15 is still in Alpha. It’s no where near a “Stable” track yet.


#4

@rtarson,

I don’t believe your problem is related in any way to Debian or Ubuntu.

The problem is that ‘Automatic Module Updates’ are enabled by default in Asterisk 15, and ‘Automatic Module Updates’ performs an INSTALL ALL modules instead of an UPGRADE ALL modules. See https://issues.freepbx.org/browse/FC-269 for a confirmation of this (my ticket was moved to ‘FreePBX Contributed’ since one of the unwanted/unsolicited modules that was installed caused a system crash).

As unbelievable as it sounds, ‘Automatic Module Updates’ is going to remain enabled by default and continue to perform an INSTALL ALL modules.

The only current solution is to disable ‘Automatic Module Updates’ immediately once installation is complete.


(Andrew Nagy) #5

Wrong.

There is an issue with certain Ubuntu systems that use PHP 7.2 which has an is_countable checking method. This breaks nearly everything in FreePBX.


(United States) #6

Oh yeah don’t get me started on that lol. I had do back date the php5.6 cause it was a utter mess with 7.2 installed. UCP was broke, adding outbound routes, few other things.

5.6 been solid but I think I may do FreePBXv14 and asteriskv15

It may be less of a headache for me. I would do freepbxnow but I’m running on AWS and the AMI is a lot for personal business use.


#7

For what it’s worth…

I just confirmed with fresh installs that:

Outbound Routes CANNOT be added in FreePBX 15 whether using PHP 7.0 or PHP 5.6.

Outbound Routes CAN be added in FreePBX 14 whether using PHP 7.0 or PHP 5.6.

The same Debian 9.6, PHP 7.0, and PHP 5.6 was used in all cases.

Note…

This is simply the result of testing this date and not any kind of recommendation as to what should or should not be used.

You should be aware that although Debian + PHP 5.6 has always been reliable with FreePBX 13/14, a GPG problem between FreePBX and Debian surfaced 30 days. This problem is fixed in FreePBX 15, but has not been applied to FreePBX 14 or FreePBX 13. Hopefully this will occur soon (although I’ve been unable to get a confirmation of this from Andrew).


(Tom Ray) #8

Again, FreePBX v15 is Alpha so bugs are 100% expected. FreePBX v14 is the current Stable release.


(system) #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.