Need help changing the default location for FreePBX GUI

Hello,
Im looking for guide how to change the loading web page on the Centos 7. I had to install manual FreePBX and i did it using this guide wiki freepbx org/display/FOP/Installing+FreePBX+14+on+CentOS+7#InstallingFreePBX14onCentOS7-AutomaticStartup There is no error at the end of the installation but now i have problem accessing the FreePBX GUI its just not showing. The only page i`m seeing is

HTTP Test Page
powered by CWP | CentOS-WebPanel com

I really need to change this and have access on the PBX. And yes i have to install it manual.
Hoping for respond on my problem also have in mind that i have low knowledge with web development and that’s why i have this problem :neutral_face:

Tried “http://my.host/admin/” ?

Thanks for responding on my topic.

Yes i have tried http:// my.ip/admin/ The requested URL /admin/ was not found on this server.

i have tried even http:// my.ip/admin/config php The requested URL /admin/config php was not found on this server.

The result is the same. But wait this might be problem with the freepbx installation ?

Yup. You can check for the web pages in /var/www/html. If the admin pages are there, you should be good to go. If not, your installation failed.

Here are additional information:

admin]# ls
ajax.php api assets bootstrap.php config.php functions.inc.php helpers i18n images index.php libraries module-builtin.xml modules page.modules.php views

ps aux|grep httpd

root 2926 0.0 0.0 88088 2952 ? Ss 17:47 0:00 /usr/local/apache/bin/httpd -k start
nobody 2927 0.0 0.0 1296640 5876 ? Sl 17:47 0:00 /usr/local/apache/bin/httpd -k start
nobody 2928 0.0 0.0 2017536 6592 ? Sl 17:47 0:00 /usr/local/apache/bin/httpd -k start
nobody 2929 0.0 0.0 2017536 6192 ? Sl 17:47 0:00 /usr/local/apache/bin/httpd -k start
nobody 3147 0.0 0.0 2017536 7136 ? Sl 17:48 0:00 /usr/local/apache/bin/httpd -k start
root 18029 0.0 0.0 112660 976 pts/0 S+ 19:08 0:00 grep --color=auto httpd

Looks like your admin page is all there. Check the configuration in your /etc/httpd directory.

Can you help me how to check it ?

And what do i need to check there

This is probably an Apache configuration problem, but there are so many things that could be set wrong, there’s no way that I’d be willing to do this one check at a time.

Log into the console and start exploring in the /etc/ directory looking for the apache config files. It’s got to be a problem in there. The reason I say that is because you are getting the default “test page” for Apache, not the one for the PBX - this tells me your VirtualHost or default home page (I can’t remember the directive off the top of my head) is not set correctly for you to connect to the admin page.

I have tried even with reinstall. I did 3 times the reinstall, found a guide how to remove the freepbx. Installation every time was successful without problems. As i said i`m not a web developer and i don’t know what to search for.

It sounds like doing a bare-metal install is beyond your scope. Have you tried using the Distro, since it doesn’t have this problem?

The problem is we are unable to use other VPS server at this moment. That;s why we are installing on Centos 7.

I’m going to defer to one of the Sangoma folks (@xrobau or @jfinstrom) on this part. I know they have a lot of experience with Virtual Servers (I don’t - I can’t think of a time when I want someone else to be in control of me getting fired when the server stops working) and they may be able to help point you in the right direction for using the Distro on a VPS.

1 Like

OK.
I know where is the problem and i need some of you guys to guide me.
The problem is in index.php
I need to change the default location /var/www/html/index.php to /var/www/html/admin/index.php

If anyone know how i can do this it will be great.

I believe that your vm’s hoster assumption that you want a webpanel is getting in your way, somewhere in

https://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-apache-config.html

you should find a solution to correct whatever it does, if it is possible to uninstall your ‘helper’ http server I would do that.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.