NAT External IP address that changes if using backup internet

We are installing a Cradlepoint 4G backup internet for your Cox Fiber which has a static ip address. The Cradlepoint device goes in-line between our router and the fiber modem. When Cradlepoint senses loss of fiber internet, it automatically switches over to supply 4G internet to our router. Only issue is, our external IP address will change.
Our Cox Fiber IP address is static, but if our fiber goes out and we switch automatically to the 4G, our external IP address is going to change. I may not always be at the office and I’m the only technical person that can make any changes to our network and Pbx. Pbx is a physical device, in house.
That 4G switchover will conflict with the Pbx Sip settings NAT address, trashing our audio for several trunks.
I’m trying to make the switching all fully automatic. Is there a way to change my NAT in FreePbx Sip settings automatically? I’ve never used a dynamic dns service with NAT sip settings, but we do use a dns service for other things.

Appreciate your tips.

1 Like

Cool thanks, I’ll tinker with this!

I don’t know much about SIP ALG, except all the posts saying to turn it off or face certain misery. I assume I would turn off FreePBX NAT handling somehow if I went the router SIP ALG route?

The ALG would look at SIP traffic crossing the NAT (your router) and adjust it with internal IP addresses for traffic heading inside and the external IP for traffic heading out. That’s the idea, but test it and make sure it works correctly. The scripted IP check solution works using your current FreePBX NAT-aware configuration.

1 Like

Thank you everyone!

Just to clarify, the sip nat setting in freepbx can’t accept a FQDN?

No, they can’t have a ‘Fully Qualified Domain Name’, they can have a ‘Qualified Domain Name’ which could be provided by your local Name Service in your local network Domain and propagated by your DHCP server. But that is a specious argument as Private namespace is not route-able on the internet

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.