MoH Stream Soft volume

When we use uploaded wavs, freepbx converts them fine, it plays loud, as loud as the tracks are normally, all good.

But using the custom streaming, its about 1/4 the volume, very soft, it uses icecast2/ezstream on the same machine, if we goto icecast on the pbx:8000/stream its loud, as it should be, so something inside freepbx is reducing this volume.

Does anyone know what this configuration option is, its obviously not a freepbx setting, but one of these thingd we need to fix under the hood in its scripting?

1/4 the volume I think is a bit exaggeration, but it is certainly less than half the volume, I’ve not looked into but I suspect it gets lost in transcoding.

That said, I’ve noticed it’s bareable on handset, but if you’re on hands free if really soft compared to the local files (which I replaced since that default crap is worse than elevator music - probably why in another thread they call it torture :slight_smile: )

1 Like

No response, you might need to open a bug if it bothers you too much, I’ve had a quick look myself and cant find the problem, but mine is not as quiet as yours it seems, its not as loud as wavs but its still acceptable

Use a sox ‘pipe’ to ‘normalize’ the volume of the stream before it gets to ice cast
if they are just files you can just pre-normalize them

man sox

in OPs first, he says if he listens directly to icecast its loud, I fail to see how normalize or sox anything before it gets to icecast is going to help him

If it doesnt work on the input to Icecast, pipe the output through sox. There is not a lot that sox (and its support libraries) can’t do with audio streams

I believe I can read, filter pissiness and also understand how asterisk processes audio streams thank you.

FYI , there is actually NO sip format for audio, the SPD session that the sip conversation will direct the session to can however be told to accept many formats (codecs) .

The “application” you are likely using in your streaming can be anything you want, if yours is too low then, you can add a pipe (or filter of the SOundeXchange program, (sox)) that can change the volume, change the frequency, add a flanger effect or most anything that it is fed to the channel, and the resultant is what you will actually hear.

FreePBX does not “grab the stream” or transcode it, that is all asterisk but it only processes what is given to it. The output of the stream that the moh ‘application’ used needs to be ‘normal’ for it to sound ‘normal’

My streams are all fine, yours apparently are too quiet, go figure why :slight_smile:

I’m aIso running icecast using a raspberry pi to stream XM for MOH. See SiriusXM for Music on Hold -How do I get from here to there? In FreePBX my streaming app is mpg123. /usr/bin/mpg123 -q -s --mono -r 8000 -f 8192 -b 1024 http://192.168.2.36:8000/mic . If your using mpg123 you can try playing around with the -g --gain option. Also you may be able to tweak output using alsa mixer (This is what I ended up doing. I increased the Mic gain). Or try Dicko’s recommendation.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.