Module Update: You have 1 tampered files


(A) #1

Hi,

All of a sudden got this error after updating,
Module: “System Firewall”, File: "/var/www/html/admin/modules/firewall/module.sig altered"
Tried force re-install refresh signatures and reset permissions…

Any ideas whats causing this? Thanks


(Rob Thomas) #2

That was me - I published a broken System Firewall module accidentally. You should be running System Firewall 13.0.1.5, which fixes that. Sorry!


(Garry Winer) #3

I have the same, or a similar issue. It happened today after I just updated the installed system. How do I fix it?


(Andrew Nagy) #4

Download the updated module like rob said


(Ronnie Betzen) #5

I’m showing a tampered file for the firewall even after updating to 13.0.1.5. Was there something else I’m supposed to do other than just updating the module?


(Rob Thomas) #6

It will go away by itself, but to speed it up, just go to the System Firewall page, which will re-check it, and the error will go away.

Sorry for causing this 8-\

Edit: I don’t recommend ENABLING the firewall yet, unless you want to play beta tester over in the other thread 8)


(A) #7

Have upgraded and went to firewall page, enabled and disabled an still showing the error. Just so you know its still there. I assume next version will fix? Please let me know if there is something else to be done… Thanks :smile:


(Rob Thomas) #8

I think that you’re not running 13.0.1.5. Can you triple check? Module Admin -> Check Online?


(Randy Snow) #9

Rob,

Thought I would chime in here, I have the same issue. Updated the distro and I’m running 13.0.1.6 with the above error message displaying. Attempted a forced reinstall with the same result. Thank you.


(Rob Thomas) #11

AHHA! Thank you so much for reporting this. Turns out it’s a subtle git side-effect of two things - using multiple branches, and me being an idiot.

I’ve published 13.0.1.7, which FINALLY fixes the signature issue, and also allows you to remove the module, too.

As I said, it’s in very early beta :sunglasses:

EDIT ARGH NO IT’S STILL THERE, WHAT THE SMEG.

RIGHT! In other news, I really should remember what .gitignore does, and not use it to help me be lazy. Properly fixed in 13.0.1.8. Sorry about that.


(Randy Snow) #12

All is well…thank you much.


(A) #13

All sorted,

13.0.1.10 all good.

thanks!


(Rob Thomas) #14

Man, I only just published that!

Reminder: Here’s the thread with development and feature requests and stuff: