Module Update: You have 1 tampered files


All of a sudden got this error after updating,
Module: “System Firewall”, File: "/var/www/html/admin/modules/firewall/module.sig altered"
Tried force re-install refresh signatures and reset permissions…

Any ideas whats causing this? Thanks

That was me - I published a broken System Firewall module accidentally. You should be running System Firewall, which fixes that. Sorry!

I have the same, or a similar issue. It happened today after I just updated the installed system. How do I fix it?

Download the updated module like rob said

1 Like

I’m showing a tampered file for the firewall even after updating to Was there something else I’m supposed to do other than just updating the module?

It will go away by itself, but to speed it up, just go to the System Firewall page, which will re-check it, and the error will go away.

Sorry for causing this 8-\

Edit: I don’t recommend ENABLING the firewall yet, unless you want to play beta tester over in the other thread 8)

Have upgraded and went to firewall page, enabled and disabled an still showing the error. Just so you know its still there. I assume next version will fix? Please let me know if there is something else to be done… Thanks :smile:

I think that you’re not running Can you triple check? Module Admin -> Check Online?


Thought I would chime in here, I have the same issue. Updated the distro and I’m running with the above error message displaying. Attempted a forced reinstall with the same result. Thank you.

AHHA! Thank you so much for reporting this. Turns out it’s a subtle git side-effect of two things - using multiple branches, and me being an idiot.

I’ve published, which FINALLY fixes the signature issue, and also allows you to remove the module, too.

As I said, it’s in very early beta :sunglasses:


RIGHT! In other news, I really should remember what .gitignore does, and not use it to help me be lazy. Properly fixed in Sorry about that.

All is well…thank you much.

1 Like

All sorted, all good.


Man, I only just published that!

Reminder: Here’s the thread with development and feature requests and stuff: