Mobile sip phone apps not registering on virgin media wifi


Ver 16.
Pbx is on our local lan at work.

I have been testing our mobile app on iOS and Android. Running fine on wifi and mobile networks. Also on a few clients mobile devices.

However at home we have virgin media fibre (1 gig) but both android and iOS fail to register.

The solution needs to be at our end as I need the sip phones to work on any wifi network.

In the work router I have port forwarded all the ports.
I turned of sip pass through as I couldn’t get audio from sip phones on mobile networks.

What magical setting do I need to change on freepbx please.

IMO, that is not a realistic goal, because Wi-Fi at (for example) schools, hotels and hospitals often blocks all ports except those needed for web access. A VPN is a possible solution (if the VPN port is open), but you would not want it always enabled, because it greatly increases battery usage.

If it’s essential that a user can connect from “anywhere”, you could instruct them to turn off Wi-Fi when on an incompatible service. When that’s not feasible, you could forward incoming as regular mobile voice calls, using DISA for outbound.

For your immediate problem, you could try using a non-standard SIP port, or doing SIP over TCP or TLS instead of UDP. Or, do some logging and packet captures to see what is actually going wrong.

Thanks for the info.

Is it just the 5060 port to change or any others.

I’ve change the sip port to 3255 in the gui. Restarted via cli

Port forward 3255 to the local IP

Tried to connect on mobile and on virgin but no registration.

It should work on mobile. ???

Reset back to 5060 and works on mobile but not virgin.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.