Message waiting issue on FreePBX in device and user mode

Using FreePBX 2.9 with Asterisk 1.8.3.3 (and .2) in device and user mode.

Message waiting indications do not show up if you leave “mailbox” field at default setting of “dev#@device.”

If you change mailbox field from “dev#@device” to “user#@default,” message waiting works - but this defeats the whole point of hot desking, which allows users to login and log-out of devices.

I can confirm that the problem does not exist on any version of FreePBX when using Asterisk 1.4.

Are you sure this is a problem with the distro. I had someone test this and it worked fine for them using the distro?

Tony,

I did verify the problem with the Distro. When you tested, did you use a dev# and user# that were different?

When I found the problem, I duplicated it on the distro by doing the following:

  1. Fresh install.
  2. Enable Device and User Mode
  3. Create Device 100.
  4. Create User 50.
  5. Register Aastra 6757i to Device 100.
  6. Call user 50 and leave message.
  7. Voicemail indication never showed up.
  8. Change “mailbox” field in Device 100 from “[email protected]” to “[email protected]
  9. Voicemail indication worked immediately upon hitting orange bar.
  10. Change “mailbox” field in Device 100 from “[email protected]” to “[email protected]
  11. Voicemail indication stopped working immediately upon hitting orange bar.
    Rinse and repeat…

Well this would than appear to be a FreePBX 2.9 issue as we do not do anything special in the Distro side. Have you opened a ticket on this yet? http://www.freepbx.org/trac/newticket

Forums generally are no used for bug reports and very rarely will it help you resolve a bug if no ticket gets opened.

Tony,

Yes, I think you’re right. This is a FreePBX 2.8 and 2.9 issue with Asterisk 1.8. The problem does not occur with Asterisk 1.4. I have opened a bug report. I posted it here since it also affects the distro and I wanted you to be aware of it.

Question: When you were unable to duplicate this issue, were you using the same device # and user #, i.e. was the device # 100 and the user # 100? I suspect that this would work fine since extension mode also works fine…

Yes that is how I had tested it

Here’s the bug report I made on the MWI issue:

http://www.freepbx.org/trac/ticket/5135

Tony, you should know that there’s a differnt bug that affects intercom/paging operations when the dev# and user# are the same. I reported that bug as well:

http://www.freepbx.org/trac/ticket/5108

But I changed “pollmailboxes” to “Yes” and “pollfreq” to “5” to get MWI updates when checking mail through the web interface.

I am using dev and user mode and have different integers assigned for the users and devices.

Are you using the FreePBX Distro (or another distro with Asterisk 1.8)?

I am using the freepbx distro with the latest updates (I have patched 2 times since initial install if I recall correctly) and installed any modules that were updated.

Only modifications I have made -

  • postfix config changes (in unix shell) for outbound mail through gmail
  • Device & User mode
  • hints changes for user/device mode listed in another thread
  • the poolmailboxes yes / pollfreq 5 change here
  • pagerbody text string

I made similar changes, but did not make the pollmailboxes/pollfreq changes. Did you make that change because MWI wasn’t working, or just out of habit?

I was looking into that change because I noticed MWI didn’t update on the phones very quickly (if at all - I never sat around and waited) when I read messages using the ARI webpage. I did some google searches and that was what I found.

So yes, the change was because of MWI but not because of the exact issue you are seeing.

Q: Before you made that change, were you using the Free PBX Distro, or an older version? In other words, did you get any MWI without pollmailboxes on the distro in device and user mode with the mailbox setting at the default and dev# and user# not matching?

I was previously using asterisknow (with asterisk 1.4) and I wasn’t using device/user mode. So I can’t really tell you how it worked for me in the past. If this change solves your problem, I would be curious if the default of asterisk may have changed between versions? Or if freepbx started writing out different config files.

I looked at my old config files on the old distro and the poll* lines are commented out, so it was using the built in asterisk defaults on the other distro.

Got it. I was under the impression (mistaken perhaps) that pollmailboxes was only needed to fix the MWI issue under Asterisk 1.6 with AsteriskNOW. MWI worked just fine with PIAF using Asterisk 1.6.

So, it sounds like you started using pollmailboxes with AsteriskNOW/Asterisk 1.6 and then just kept using it as a matter of course with the FreePBX Distro, and so you’ve never tested FreePBX Distro in dev and user mode with dev# and user# different without pollmailboxes.

Could you do me a huge favor? Turn pollmailboxes off, issue an amportal restart command, see if MWI stops working, and then report back?

First, to clarify, this is the first time I have used the poll* commands under freepbx.

Just did your experiment -

  • Changed poll mailboxes to “undefined”
  • Removed “poolfreq”
  • Clicked “update”
  • asterisk -rx “core restart gracefully”

I have a phone with 3 lines -
Line 1 / Device 6110 / Fixed User 6000
Line 2 / Device 6111 / Fixed User 6051
Line 3 / Device 6112 / Adhoc no default

Called 6000 from line 2. Left message. Hung Up.
No MWI on any of the lines.
Logged Line 3 into 6000. Still no message on any lines.

I put back the 2 poll* settings, restarted asterisk, and then the phones worked as expected. Line 1 always shows MWI and Line 2 shows MWI if I login to 6000 and clears when I logout.

Hope this helps.

Have you tried adding the poll settings?

Question: When you say you changed pollmailboxes to “undefined,” do you mean that you put a semi-colon in front of pollmailboxes? Or that you changed pollmailboxes to read:

pollmailboxes=undefined

or that you changed it to

pollmailboxes=no

I’m still using FreePBX 2.8 with Asterisk 1.4, and it works just fine with ;pollmailboxes (i.e., no pollmailboxes). I was testing the FreePBX Distro last weekend when I noticed this behavior. I honestly can’t remember what I did with pollmailboxes=. I think I tried uncommented it, but I don’t think that I changed it to =yes, and I’m almost certain (but not absolutely certain) whether I uncommented pollfreq=.

Given, what you’ve said, however, it sounds like MWI will work in the circumstances I’m reporting if you uncomment pollmailboxes, change it to yes, and uncomment pollfreq. I’ll try it when I next get a chance (probably not until the weekend).

I changed the settings in the voicemail admin module in the freepbx gui.

Of course! :slight_smile:

Since I’m still using 2.8 as my primary interface, I didn’t even consider that!

Thank you very, very much for your input. I’ll re-test when I have a chance and post the results here. It sounds like pollmailboxes and pollfreq are required settings when using device and user mode with Asterisk 1.8.

I finally got around to testing this, and yes, it appears that if you enable device and user mode with Asterisk 1.8, and if your dev# is different from your user# (i.e., extension#), message waiting will not work unless you also enable pollmailboxes.