Message waiting issue on FreePBX in device and user mode

I’ve updated the FreePBX documentation about enabling Device & User Mode to reference the need to enable pollmailboxes. Here’s the article:

http://www.freepbx.org/support/documentation/installation/enabling-device-and-user-mode

Just to confirm, when User & Device Mode is set to Extensions with Voicemail settings not using polling of mailboxes (ie pollmailboxes is “undefined”), “mailbox” on extensions needs to be set to [ext]@default. I had mine set to @device and MWI did not work. We are on FreePBX 2.9.0.7 on Asterisk 1.8.

I believe the solution you propose would work with Device Type “Fixed”, but wouldn’t work as expected for AdHoc with users logging into a phone.

I agree with brk.

The better solution is the one I’ve stated above, and written into the documentation, which you can find here:

http://www.freepbx.org/support/documentation/installation/enabling-device-and-user-mode

I know this post is a year old but I found it when searching for the reason my MWI light wasn’t working on a snom phone so I guess other people may also be looking and find it. I am using freepbx from the distro 2.9.0.12

Previous posts refer to device and user mode as opposed to extension mode- Extension mode is the default mode. the links above give more details.

Pollmailboxes and pollfreq are settings that can be found in Setup menu,Basic,Voicemail admin, settings.

I changed pollmailbox from the undefined(default) to yes and pollfreq to 15 then clicked submit, I expected that the normal orange bar would need a click but it didn’t appear. the page did refresh and if I scrolled back to the bottom where the submit button was there was an update completed message but it still didn’t work, I found that on this occasion an amportal restart did the trick, the settings took effect and the MWI now works.

I also found that changing mailbox to [email protected] in the Device options section under Extensions; made the MWI work but their is a warning saying not to change the setting unl;ess you know what you are doing so I guess this isn’t the way to get it going.

hope my comments are useful to someone. if it was possible to add them without sending the thread back to the top of the forum I would have done.

Dave

I too have noticed with distro 2.9.0.12 that while in extensions mode (not device and user) extensions are created with ‘ext#@device’ which doesn’t seem correct. I do see the symbolic link within /var/spool/asterisk/voicemail/device pointing to the default folder, and as far as I know, messages are available, but MWI is not working. The fix being to change the extension setting to ‘ext#@default’. Is this a bug while working in extensions mode, or as mentioned above, does turning on mailbox polling fix this? I assume it would be a better fix to point the extension to the proper mailbox context in the first place and avoid turning on an extra process to poll mailboxes.

I just did a fresh 1.89.210.57-2 install. I setup in deviceanduser mode. What I found was the defaults in the voicemail admin -> settings menu appeared to be changed to reflect pollmailbox=yes and pollfreq=30, but the vm_general.inc file did not reflect those settings (those lines were commented out).

I clicked apply at the bottom of the voicemail admin page then noticed that vm_general.inc was updated to the new values.

Perhaps a defaults don’t match?

-Brian