Low volume during calls

Hi, I have this problem in my freepbx 16.0.19, when a call is established we hear very low and also the person on the other side hears very low.
I have tried to edit the volume gain TX and RX from 0 to 10 but it only increased the noise, I also tried in the web gui to increase the DB gain in the global dahdi setting but again nothing really happened, any tips? thanks
-Matteo

What phones are you using? Try to increase the mic volume.

Some grandstream and unidata and gigaset, all the same problem, before freepbx we had 3cx and they were working fine, so it cannot be a problem of phones, also they are at max level, i have also a grandstream ht813 for the trunk, we checked some parameters there, but they seem fine, I don’t know what to do cause it’s really difficult to talk with this problem

Those don’t use DAHDI.

VoIP preserves volume levels end to end, so you should not need to do gain corrections.

ok thanks, what should I do then?

I think you need to provide a better description of your system. If it is purely VoIP, and changing the phone doesn’t help, it is really strange and suggests you are misusing the phones is some way. Amplitude should only be a problem if you have analogues lines somewhere between you and the other party. Once a signal is coded digitally, its amplitude cannot degrade; it would require a new digital value to be computed.

ok I can try.
I have an analog line from my provider (TIM), then I have this line entering the grandstream HT and I use the fxo port only not fxs.
I had set the ip address of the pbx and the user to connect to it, everything fine.
then in the grandstream I have some parameteres about dial tones, I set it specifically for “italy” then there is a TX and a RX gain that i set on +6db & +6db (these are the recommended and also the maximum).
So these parameters basically are the same I used in an other installation in a house, and it works fine, so i was wondering if nothing is wrong on the HT so maybe it is on the PBX, and maybe there are some gains that i am not able to find.

mine Freepbx config is not so complicated I simply have a trunk with this setup :
host=172.16.xx.xx
type=friend
context=from-trunk
authname=10000
secret=xxxxxxxx
canreinvite=no
insecure=very
dtmfmode=rfc2833
qualify=yes
nat=no
port=5062
disallaw=all
allow=ulaw

then also a Incoming route and Outbound route that basically do nothing, they simply just accept every type of call.

In advanced settings sip i use this codecs :
ulaw
alaw
gsm
ilbc

Sip is a chansip legacy and not a pjsip

So basically it’s a nearly default settings on the pbx config.

Maybe I missed something and I can’t find a solution.

If you need anything else, please tell me and I will provide all the info.

Thanks so much.

As far as FreePBX/Asterisk is concerned, you have a VoIP only system. Any volume normalisation should be done in the Grandstream HT, or the underlying fault, in the analogue line, should be fixed.

In any case, if increasing the receive gain increases noise, you have a line with poor signal to nose and extra gain will not improve that; it has to be fixed in the network. Increasing the transmit gain is likely to result in clipping and resultant distortion, although it could improve signal to noise ratios.

The only codec that makes any sense in this context is the one used in your country’s national digital network. which will be ulaw or alaw. With the general quality, it probably doesn’t matter which of these, as it is not digital end to end and the analogue line is poor quality.

ok thanks so much, I will try to fix it. thanks a lot!