Issues after a restore on a brand new install

Hi,

I had to migrate off my on-prem server to a cloud hosted server. I verified they were both running the same version then backed up the existing server and restored it to the new server. I ran some module updates from the module admin.

I then went into my extension and just for funsies I made a password change on my voicemail box. When I went to apply config, the following 2 errors came up.

Error 1***************
retrieve_conf failed to sym link:
/var/lib/asterisk/bin/fax2mail.php from fax/bin (Already exists, not a link)
/var/lib/asterisk/bin/storage.php from sysadmin/bin (Already exists, not a link)
This can result in FATAL failures to your PBX. If the target file exists and not identical, the symlink will not occur and you should rename the target file to allow the automatic sym link to occur and remove this error, unless this is an intentional customization.

Error 2*****************
exit: 1
[FATAL] SQLSTATE[HY000] [2005] Unknown MySQL server host ‘localhost:3306’ (2) SQLSTATE[HY000] [2005] Unknown MySQL server host ‘localhost:3306’ (2)

Trace Back:

/var/www/html/admin/libraries/BMO/Database.class.php:70 PDO->__construct()
[0]: mysql:host=localhost:3306;dbname=asteriskcdrdb
[1]: freepbxuser
[2]: [Removed]

/var/www/html/admin/modules/cdr/Cdr.class.php:35 Database->__construct()
[0]: mysql:host=localhost:3306;dbname=asteriskcdrdb
[1]: freepbxuser
[2]: [Removed]

/var/www/html/admin/libraries/BMO/Self_Helper.class.php:116 Cdr->__construct()
[0]:

/var/www/html/admin/libraries/BMO/Self_Helper.class.php:36 Self_Helper->autoLoad()
[0]: Cdr

/var/www/html/admin/libraries/BMO/Hooks.class.php:163 Self_Helper->__get()
[0]: Cdr

/var/www/html/admin/libraries/BMO/Hooks.class.php:37 Hooks->preloadBMOModules()

/var/lib/asterisk/bin/retrieve_conf:26 Hooks->updateBMOHooks()


I verified the password, port and existence of the DB via SSH. I verified as many files as I could find that had reference to that connection string.

System Info:
FreePBX 12.0.71
PBX Firmware: 6.12.65-28
PBX Service Pack: 1.0.0.0
Asterisk (Ver. 11.18.0)

Any help is GREATLY appreciated

Sounds like the same problem I had after updating. Thanks to some great assistance the problem was solved by changing the Remote CDR DB Port to nothing from 3306.

To verify, just login to Mysql, use the asterisk db and run
select value from freepbx_settings where name=‘Remote CDR DB Port’;

If it comes back with 3306 remove it.
update freepbx_settings set value="" where name=‘Remote CDR DB Port’;

You sir, are a champion! I’m surprised I didn’t find your thread, I search EVERYWHERE before posting. :confused:

It solved both issues. Thank you for the help!