Issue with restoring from backup


#1

Hello all,

I am experiencing another problem in the fun world of freepbx. I am upgrading another one of my company’s systems. I believe the version of the old pbx is 2.11.0.43. image
Firmware is 4.2111.64-5. I am upgrading this to version 15. I have been doing what was recommended here by creating a new installation of 15, and restoring from a backup of the old version. With my other servers so far, most config has made it over with the restore. This server however has brought nothing over from the restore. No trunks, no inbound routes, no extensions, no follow me, no ivr. I’m not even sure what else to look for as I am still a noob but I know that barely anything made it over from the restore. I have followed the guide online to create a full backup https://www.freepbxhosting.com/blog/complete-freepbx-backup/. I have tried the restore twice now and nothing comes over. Is there any other way for me to do this? Thank you in advance for any help.


No endpoints or peers after upgrade
#2

I saw another post about this with a similar problem. They stated to go to /var/spool/asterisk/backup/uploads and chown asterisk:asterisk a file that was uploaded, and then restore directly from that in the gui. I have done this but do not see the uploaded backup in the gui anywhere.


#3

Any help would be greatly appreciated. The only other way I see to move these files over is manually. I assume I could copy the files directly, but I don’t know where all the files are that would need to be moved over.


(Itzik) #4

Can elaborate a bit more? Have you tried restoring from command line? Does it give you any errors? Did you confirm that the backup file contains valid data?


#5

Thanks for your response PitzKey. I’m not sure how else to elaborate. No configuration was restored from the backup. There are no inbound/outbound routes, no call recordings, no time groups/conditions. No config was brought over from the restore. I have not tried restoring from the command line, I did not know that was an option. I also do not know how to confirm if the backup file has valid data. Could you please tell me how to do that?
My colleague did state that this is version 2, and it doesn’t look like a direct restore from 2 to 15 is possible?? I’m not sure about that, but that seems to be the case right now.
I found this post https://community.freepbx.org/t/best-path-to-upgrade-freepbx/60883 which is stating to use a conversion tool to go from 2 to 14. It says this is old and has been replaced by the backup & restore module in v15, but that is what I’m currently getting failed restores with.


#6

I ran a backup via the command line and it seems like a lot more config has made it over. I don’t see the call recordings though. Is there any other way to import this? I was trying on Friday to import certain sections of the config, call recordings was one of them. I copied the directory /var/lib/asterisk/sounds/custom to my pc and copied it to the new vm. I ran chown asterisk:asterisk * in the new /var/lib/asterisk/sounds/custom directory that was created on the new v15 vm. I see the files in the directory, but they do not pop up in the gui.


#7

I’m sorry, when I was saying call recordings before, I actually meant system recordings. They have made their way over. I believe the cli restore did the trick. Thank you very much PitzKey!


#8

If anyone is looking at this thread. I have run into a restore problem on another one of my site’s pbx servers. This is another site that is going from FreePBX 2.11.0.43 to version 15. Due to my last box that was on this version failing the restore from the gui, I figured I was going to have to do the cli. I tried the gui restore to get the file to the /var/spool/asterisk/backup/uploads directory. The gui restore got stuck at 99.99%, then got stuck at 100%, and then went through on the third try. Like I figured, no config was brought over from the gui restore. I then attempted cli restore and this is the error that I got. You can see the command used for the restore in the pic that has been provided.
image
Any help would be greatly appreciated with this.