Issue with incoming calls


#1

Hello,

A client from us has some issues with incoming calls. Since a few weeks - beginning of September - when someone calls, it rings, pick up, but no audio. If the same callers calls again, it may work eventually. The issue only is for incoming calls randomly. No issue at all for outgoing calls.

The client has FreePBX for over 2 years installed, the issue started early September. We haven’t changed anything at the installation. Any chages to the infrastructure is not known for us.

I would like to ask the community for some ideas to troubleshoot the issue. My first thought was audio codecs. Could you also please tell me which FreePBX log file contains information about calls in detail… Used codec with negotiation phase.

Thanks,


(Dave Burgess) #2

My first thought was that the ITSP may have added a new source for incoming calls and there isn’t a trunk defined for those calls.

The /var/log/asterisk/full log should have a lot of details that will assist you in your troubleshooting.


(Lorne Gaetz) #3

Signaling without audio is a NAT issue. Try the originate test in this post and see what happens. SIP Port Forwarding


#4

I have a similar problem with 3 of our systems:

Someone answers an incoming call, no audio. He hangs up the phone, it rings again immediatly and now the audio is fine. I’ve opened a case with the SIP provider and I am waiting for an answer from them. The 3 systems with the issue have this in common: there is no IVR, the incoming calls are directed directly to a phone.

I will try to have more info with a capture.


#5

Hello - Thanks so far for your replies. It’s helpful.

@chrischevy - We see similar things - from 3 calls it works 2 times.


#6

One thing I noticed is that all affected systems are on Chan_SIP
It’s a NAT problem for sure on my side because packets are sometimes sent to the internal IP of the phones but my systems are clouded. (I see it in the captures). This means that somewhere in the SIP negociation, the internal adress shows up instead of the external adress.
I not really good at explaining it but I see the problem. I will try to switch to PJSIP as soon as possible to see if it resolves the issue.


#7

Ok I can’t find where the problem comes from.
To resume everything:
FreePBX is clouded
Phones are behind a router, no ports forward, no SIP ALG
A call comes in, the phone rings
Someone answers but all that person can hear is echo from his own voice
The person hangs up the phone
The phone rings again and everything works correctly
Happens only to systems without an IVR (a receptionnist answers)
Happens only to systems which are on ChanSIP (so far)

I just inserted a “dummy” IVR at the start of the incoming route with no recording. It timeouts after 2 seconds then forward the incoming call to the right destination. I will be able to confirm if it works pretty soon.


#8

I noticed in the FreePBX system NAT is enabled. Shall I disable it? Could this be a possible fix? Actually, I’m not sure, since this is active from the beginning and it worked fine for almost 2.5 years until the beginning of September.


(Dave Burgess) #9

NAT is a “one direction at a time” kind of service. You need to verify that the extension configuration has NAT turned on, as well as NAT support for your SIP connections at the server. If you are using Chan-SIP, you need to enable this by hand in the trunk definition.

On the phone side, you need to make sure the phones know their ‘external’ address so that the PBX can route the call audio to them through the firewall. If you are using STUN on the phones, that could easily cause a problem like this, especially if the STUN server you are using has decided to “go commercial” or is simply flaky because of some weird combination of hardware and human errors.