FreePBX | Register | Issues | Wiki | Portal | Support

Issue with Freepbx when loosing Internet connecvity


(N G) #1

I have notice a strange behavior that cause loosing all phone calls on freepbx system based on distro when Internet connection is down. for some reason system become unstable and very slow plus all phone calls are being not answered and a huge lag on all extensions

Is there any kind of activation or online check that runs in background and may cause this ? we notice this because switching to another gateway with Internet connection solved the issue immediately

Asterisk version: Asterisk 13.18.4 built by mockbuild @ jenkins7 on a x86_64
linux version 3.10.0-693.11.1.el7.x86_64
freepbx version FreePBX 14.0.4.5


(Mvogel4949) #2

If I remember asterisk slows down in an attempt to resolve the urls you have for sip hosts. One way to handle this is to replace the url with an ip. There are obvious drawbacks to this as well but asterisk is not a fan of not having the internet and trying to resolve web addresses.


(N G) #3

THanks for the quick reply but actually all phones are local and we use only PSTN lines, there is not sip addresses, for sure we want to keep Internet but you know this call center is active for 24hours and sometimes ISP has failures


(Tom Ray) #4

What happens if you remove the PBX’s access to the Internet? If you are using POTS lines for PSTN connectivity (or PRI) and the phones are local, what happens when the PBX is only allowed to be local?


(N G) #5

we plan to do the test but we cannot now(we have few remote users, 5% of the total users), we faced these troubles multiple times but we never thought this is related to the internet connection, now 1 hour ago when problem happened we figured out it’s related to internet connection,
we will give it try and share the information, thank you


(Itzik) #6

IIRC, there was someone here who posted a very similar if not the same issue as you discribed. (probably around a year ago)

I don’t remember what solved it, try searching.


#7

If you rely on a local caching server like dnsmasq, you can largely survive short term internet disruptions if you use 127.0.0.1 as your primary name server, but be wary of allowing port 111 (rcpbind) through your firewall


(N G) #8

thank you for your help, I already figured out it’s more likely a DNS issue then routing issue, we are monitoring any failure but the strange behavior is the lags on local extensions when DNS failed


(Tom Ray) #9

Are you using Chan_SIP or Chan_PJSIP for your extensions and/or trunks?


(N G) #10

most of the extensions are local and we use chan_sip what is the difference in such dns issue between sip or pjsip ?


(Ast Box) #11

The chan_sip is broken. If asterisk registers somewhere and a domain is used to specify the registration host then if for some reason the dns lookup that asterisk makes from time to time fails even once the chan_sip fails and everything stops working even local phone calls.
It doesn’t matter if you don’t register to a sip provider, the clue is you register to somewhere and if you are using a domain name as a target.