Is this just me. Reload apache after module update

When new/upgraded modules need an Apache restart we are notified with:

After we click the reload button we are greeted with:
Please Wait-FreePBX Administration — Mozilla Firefox

My page never reloads on both of my FreePBXes. Even after manually refreshing the page I am still greeted with the restart Apache.

Should this reload button and notification not disappear after a successful reload?
Did I have a successful reload?
Should I drop to a command line and restart Apache?
Or just ignore it after a couple of mouse clicks?

Thanks!

probably a bug. I don’t know how they are “watching” but something is probably incorrect. In any case you can restart from the CLI. I don’t know if that is enough to clear the flag but ultimately that is what it wants.

I’ll report it. Thank-you.