Ip-phone registered but it is unavailable on freepbx

hello everyone I hope you are well I have a problem with the configuration of my IP phones. I installed Ubuntu 20.04 on which I deployed freepbx 16.0.40 following this I created my SIP extensions (CHAN_pjsip) precisely 2. which I assigned to two of my ip-phones. the problem is the following when I record on my IP-phone everything is okay but on my freepbx it shows unavailable. and since then I’m running out of ideas, could someone help me?

Not without logs.

It looks like 102 has failed to respond to an OPTIONS request sent to test connectivity.

Does the phone consider itself registered. If not there is no return route to it. If it does, it is possible a temporary firewall, or port forwarding, rule was opened in a router, or in the machine hosting the extension, which has timed out.

It is just possible the phone is broken, and ignores OPTIONS.

Generally we prefer logs as plain text, from the full log file.

this is my ipphone interface and it show registered. how can i provide you logs as plain text please


This is probably a legacy copy. A reorganisation of the documentation means I can’t find the latest one.

Some people recommend using the pastebin.com server, rather than the freepbx version, because the latter now expires quickly. To benefit from this, you need to specify an indefinite time limit. The aim is the forum post still contains all the information when someone comes back to it in five years time.

this one can help

You are not getting a reply. You need to find where the outbound or response message is getting lost.

Whilst you could turn off the qualify feature, unless the phone is broken, a failure of qualify also means a call to the phone will fail.

Check that the addresses are what you would expect.

which adress

The OPTIONS is being sent with a Via header containing your (Cameroon?) public IP (it should be, and the phone is likely not heeding the rport tag, so it is responding to the public IP and the response is probably blocked by the firewall.

In Asterisk SIP Settings, confirm that Local Networks includes . If you change these settings, after Submit and Apply Config, you must restart Asterisk. If you still have trouble, paste a log with the failing OPTIONS.

hello S

tewart1 I applied your advice but so far nothing. I added the network save then restarted asterisk I will leave you the captures thanks in advance


This will be fatal for supported versions of FreePBX. Macro has been deprecated, in Asterisk, for a long time. but FreePBX is heavily dependent on it. I assume you installed Asterisk independently of FreePBX. I think the latest version doesn’t have Macro, and other current supported versions won’t include it by default.

I’m not sure if FreePBX 17 avoids Macro, but that version is still a work in progress.

ok thank you for your support, what do you advise me to install a new version? if yes which one? currently I am under ubuntu20.04

FreePBX 16 should be fine, see

If you still have more problems like this, consider the FreePBX Distro, rather than building it yourself.

hello Stewart I installed the module in question via make menuselect but now asterisk no longer connects

i receive this message when i log in my freepbx web interface “Asterisk is not connected

Just guessing that the Asterisk reinstall overwrote some setup that the FreePBX install did.

Can you do one of these?

  1. Start over, using the Distro.
  2. Start over with your Ubuntu install, doing the proper menuselect.
  3. Repeat the installation steps you took after building Asterisk.

If not, search for the error you are getting and try to recover. Sorry, I don’t know how these pieces interact.

thanks for your support

Also, Asterisk 16 is no longer supported by the Asterisk project, so you should get support for that from Ubuntu.