Outbound calls fail with 'No application 'Macro' for extension'

I’ve installed freepbx 15 with asterisk 16 on centos 8 and restored a backup form a freepbx 13 machine. I can’t make outbound (or inbound) calls. outbound call fails with No application ‘Macro’ for extension. when I installed asterisk 16 I enabled app macro. I’ve also tried disabling app macro with make menuselect but I’m still getting this error. thanks for any help.
ps: I can’t call another internal extension either, it fails with the same error message

Make sure it’s not being noload’ed in modules.conf.

From the asterisk CLI, what does

module load app_macro

return ?

app_macro is not included in the Asterisk16 build. You will need to rebuild Asterisk and include the app_macro module.

I checked /etc/asterisk/modules.conf and app_macro isn’t even there and yet when I do make menuselect during the build app_macro is selected with a *
is there another way to double check if app_macro is actually there?

[2021-09-09 18:40:19] ERROR[13374]: loader.c:283 module_load_error: Error loading module ‘app_macro’: /usr/lib64/asterisk/modules/app_macro.so: cannot open shared object file: No such file or directory

hmm so app_macro doesn’t appear to be there. is there another way to install it?

You have to select it when you ‘make menuselect’ before you compile and install asterisk, just as it says in the recipe.

but thats exactly what I did, I selected app_macro before I compiled

If it’s not there, maybe there was an error building it. Run the build again and see. At the end, run make install and it should put everything in place without overwriting your existing configs.

I’m not a RedHatted guy in any way but did you ./configure with --libdir=/usr/lib64

https://computingforgeeks.com/install-asterisk-18-lts-on-centos-rhel-linux/

yes
./configure --libdir=/usr/lib64 --with-pjproject-bundled

then that’s not the problem. Are ALL the modules being built in /usr/lib64 ?

@billsimon yes you were right, I checked and there were errors during the build.

what errors? (just in case we can save you some hair)

Often you might need to install the ‘pre-requisites’

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.