Intercom all record

Hello, tell me how to record conversations on the intercom?

I found the intercom in the file extensions_additional.conf (am I editing the parameter data correctly in it?)


but this way the recording is not performed…

As soon as your Apply Changes, your change will be overwritten. If you’re going to do this, you’re going to need to use extensions_custom.conf or the “extensions override” config file.

I’m also pretty sure that some of the parameters you are trying to pass to MixMon aren’t preset for you, so you’re probably going to need some variable setting steps in your context as well.

thank you for the quick response, I do not know the configuration files very well, can you give an example to start?

I’ve found that one of the easiest ways to learn about contexts is to look in /var/log/asterisk/full.

In there, you will find examples of contexts being actually executed, including the setup steps. For example, your MixMonitor() looks perfectly sensible, but look for that in the log file and you’ll see dozens of steps setting that function call up.

One last item - I don’t know about Intercoms at all, but this doesn’t seem like something that would work, even if you get the syntax right. Intercom traffic is handled on its own merits, so MixMinitor() may or may not be able to interact with the Intercom subsystem.

1 Like

Are you looking to only record this call when it is answered via Intercom mode or just record the call in general? The first option is going to require custom dialplan while the second requires you to enable call recording on the extension.

Well actually, you need to enable the call recording on the extension regardless.

1 Like

me interested in the second option, record on these numbers included. but he doesn’t.

so I started looking at the configuration files.

As Tom said, you don’t need to make this change on the backend. You can do it in the GUI on the extension.

I cannot find this parameter.

which is responsible for the Intercom

You aren’t making sense. Call Recording has nothing to do with the Intercom. Intercom is a method of calling the device and sending an Auto Answer request to the device. Call Recording doesn’t care if the call was auto answered or answered just that it was answered and it will record the audio.


Dear Tom,

I understand that intercom recording and telephone conversations are not interconnected. But I don’t understand how to record conversations on the intercom. (I read the Internet and documentation, I can not find what I need).

Set Recording Inbound Internal Calls to force.

no, it doesn’t help.

On which extension did you enable it? Receiver end?


No… Go to extensions, click on the extension, advanced settings and do what I mentioned earlier.

what extension? if that’s what you mean, he’s not here.


that’s where I installed force

Is this in the extension settings, or settings > advanced settings?

no, this item does not have these parameters.

FreePBX 13

Can you post a screenshot of that extension’s settings?

Yes, which item?