Installation on Virtual Machine (mac) fails repeatedly with same anaconda arror


(Francois) #1

Hi,
I have tried half a dozen times to instal SNG7-FPBX-64bit-2011-5.iso on a virtual machine on a mac but it always fails the same way (attaching screenshot).

I have tried on 2 different Macs, on 2 different VM solutions (Parallels and VirtualBox) and I also installed as “other linux”, “other linux 64 bit” and “red hat 64 bits”. Always the same error.

I do have other virtual machines running fine on both servers.

What should I do?

Is there another way to install? Like a pre-built VDI disk image?

Thanks.


(Francois) #2

I can’t find how to attach a screenshot…

The same error occurs wether using GUI install or fully automated install.

anaconda 21.48.22.147-1 exception report
Traceback…
File /usr/lib64/python2.7/site-packages/pyanaconda/iutil.py line 415
(followed by 1000 other lines…)


(Francois) #3

I was also able to install CentOS successfully in a virtual machine. (CentOS-8.3.2011-x86_64-dvd1.iso)

What am I doing wrong with the FreePBX distro?


#4

I know almost nothing about Mac, but there are several guides to installing the distro .iso in VirtualBox, for example


The above guide used an older version (1805) which you can find at
https://downloads.freepbxdistro.org/ISO/
If that works, you could then upgrade to current.
If it doesn’t, at least you’ll know that the problem is Mac specific.

You can upload a screenshot by dragging the .png file onto the compose window, or by clicking the upload button at the top of the compose window.


(Francois) #5

Thank you for the link to the previous ISOs, I was looking for that on the downloads page and could not find it.
I am downloading a previous release now. It’s taking hours to complete :wink:

Screenshot from earlier:
2020-12-14_23-45-01


#6

From here, the server seems pretty fast. Took about 2 minutes to download, limited by the speed of my 100 Mbps connection.

I found this: https://bugzilla.redhat.com/show_bug.cgi?id=1855503
and it turns out the guy had a corrupted .iso file. Did you check the md5sum or sha256sum for the original file you downloaded?


(Francois) #7

Wow! You just made my day and blew my mind off at the same time! Thank you!

  1. I do have a corrupted .iso or at least the md5 doesn’t match. I tested with 2 host machines, 2 virtualization systems and I even tested with a plain CentOS… but somehow it didn’t occur to me that I should test with 2 different ISOs of FreePBX… It sucks getting old :stuck_out_tongue: I think I used to be smarter than that :’(

I had never checked an md5 checksum in 20 years … and never had a corrupted file either since we don’t use floppy disks anymore. How is that even possible with https and tcp/ip supposed to do error correcting? That leaves me baffled, but I’ll know better for next time :wink:

  1. I let a download run for the whole night and it just got stuck… despite having a 500 Mbps FTTH connection… but in Europe… In case you know about a mirror server, I’ll gladly take it :slight_smile:

  2. I redownloaded 1805-2, went faster this time (but still a couple of hours), checked md5 (matched) and was able to install it without error.

I am currently redownloading the latest ISO in hope of getting a correct checksum this time :wink:

Again, thank you so much for showing me where my thinking failed :wink: