Install of FreePBX distro fails on VMware

After installing the latest distro (from here: https://www.freepbx.org/downloads/freepbx-distro/ ) over VM, when I log in, I get the following:

** CRITICAL SYSTEM ERROR **

Unable to generate MOTD.
The /usr/sbin/fwconsole file is not accessible

You are likely to experience significant system issues.

HELP please. What should I do?

You didn’t supply internet access while installing the distro.

Indeed, it looks like the lack of network was the reason, but it was not the main problem (just a symptom of the problem).

The main problem was that the installer is not geared up to comply with installation over VM. There were two alternative outcomes to that: (a) in some of the attempts the installation did not let me to define the network parameters. It simply skipped this stage. OR (b) it did allow me to change the network settings, but did not allow me to SAVE them!

It took a lot of time of attempts and playing around with various settings of the VM to go through a full successful installation.

Bottom line - the installer must be re-visited and tested over VMware environment (all their products). Currently it is not in production stage for VM settings.

I can assure you we install in VMs daily here the Distro with no issues including ESXI, KVM, Proxmox and VMWare. At this time yes you need to have internet at install time. If you find a bug with something specific with your installer than open a bug report at issues.freepbx.org

After spending too much time on this problem (about 3 days) I am not going to do that again and reproduce the problem for you.

The facts are the following:

  • there was internet available all the time to the VM
  • but it was not detected during the installation, and
  • the installation kept skipping (in most attmpts) the option of defining the network parameters, OR
  • didn’t let me save them in the cases were it didn’t skip that.

Only after some manual tweakings I have managed to install.

If you google it a bit you will find that others were facing similar problems. Someone used the term ‘hijacked’ to describe how the installer was skipping this part. I can relate to that and confirm the frustration. It was very clear that the installer needs network parameters, but did not allow me to set it up properly.

QA that properly and you will see it for yourself.

Our entire development setup is based on VMWare. So I can assure you that we have been QAing.

Hi!

Which NIC did you use for your VM?

People which upgraded to FreePBX 14 using the distro upgrade “script” had to use e1000 and not a VMNet specific one.

Re:

It is quite possible that the same issue might exist for a new install of FreePBX 14/Sangoma 7 and not just an upgrade.

Good luck and have a nice day!

Nick

I just installed and it worked fine so if you don’t want to open a proper ticket with screenshots of what you are saying does not work than I can’t help you anymore.

I believe you but still it took me 3 days to install it properly. There is a bug there. I have over 30 years of expereince in *nix systems to tell that. Instead of denying, listen to a compliant of an expereinced customer.

That’s interesting. I didn’t see this article before. I will check tomorrow.

Your complaint doesn’t help. I and our QA staff can’t replicate. Please outline each step you took during installer and what did not work for you. I can’t guess or read your mind. Their are alot of options at install time of things you can pick so I have no clue which path you took.

If it failed everytime for you over 3 days of trying it should be easy to replicate on a new VM for you and document what options you picked and what the outcome was.

Heya ybz! I’ve just been pinged to check out your post, as you’re having problems with VMware.

I have some good news for you - I know what the problem is! The bit you didn’t mention is that you’re using VMware Workstation (or Fusion, or similar). That has a built-in helper to help you install your VMs, and unfortunately, it doesn’t work well with OS’s that try to do smarter stuff in the installer (like we do).

The way to resolve this is to create the VM first. Do not attach the ISO to it until it’s booted (or, select ‘I will install the OS later’). That will stop VMware from fiddling with the boot process, and breaking everything.

Unfortunately, there’s no way I can STOP VMware from doing this, as it replaces the kickstart at install time.

The upside is, I’m 100% certain it works on VMware, because I use it for everything 8)

1 Like

I missed that thread, but that’s fixed - We install open-vm-tools by default now, which also makes sure all the virtio drivers are working.

1 Like

No, I am using VM vSphere and VMWare ESXi. The option of “installing the OS later” does not exist there.

Well I’m stumped as to what your problem is then. I’ve only recently upgraded to 6.5 from 5.5 everywhere, and that’s where I do all the development work for the distro! So that is the first place that stuff should work!

Can you go through exactly what you are doing, step by step? And can you post a hash of the ISO, please? You may have a corrupt image. (Also, and it may not be relevant, bur are you using the Flash or HTML5 interface? Or Fat client?)

Well - as mentioned above - at last, after many attempts and tweaking, I have managed to install. To be honest, the last attempt, the successful one, was late last night and I don’t recall exactly what I did, but it worked!

I am not going to try this again. It was frustrating enough.

What I can tell is that I had to delete the VM each time and start from scratch. I did select “Other Linux kernel 3.x” as te OS. I did mount the ISO file from the start (had no other choice). As mentioned earlier - this (last) time, I’ve managed to halt the installation and fill in the network details (in previous installations), the installer either did not get to this setting screen at all, or displayed it for a very short time and moved on, without letting me the opportunity to feed it.
I might have made more changes to the VM settings, but I really don’t recall. Sorry.

Then there is something broken with your system. This works 40-50 times per day. Every day.

You don’t need to do that.

It should be ‘RHEL 7’ or ‘CentOS 7’

If you don’t want an automatic installation, you should have picked ‘Advanced’ and selected manual.

This is how I create a new VM. Pick RHEL7 and delete the Floppy, that’s all you need to do.

Oh, yes, I had to. I’ve tried many times without deleting the VM and it didn’t work as well. There was also an issue with re-partitioning at some point that simply did not work. At some point I realized that it is better to start from scratch each time. Saved me time and trouble.

Well - this is where I started off (CentOS 7). After reading some posts of others that suffer from such issues, the recommendation was the same - go with the “Other Linux kernel 3.x”. I don’t know if this is indeed at the core of the problem, but at the end it worked.

There was no such option.

I admit - this is the only thing I didn’t do.

Well, I don’t know what to say. I’m leading back to your VMware infrastructure being broken. The install, by default, deletes the entire partition table, and zeros the first and last 1MB of data on the disk, specifically to avoid these issues.

It’s the 4th option.

Could be, although it is working eventually.
How this can be checked?