Incoming Calls are working but no outgoing calls!__Newbie_HelpRequired

configuration
freepbx
Tags: #<Tag:0x00007f7030ec7190> #<Tag:0x00007f7030ec6ec0>

(Lemillion) #1

I have a SIP Trunk configured and is registered in FreePBX. The SIP is registered and incoming calls are working properly whereas the outbound calls are failing with All Circuits are busy now, please try your call later; prompt. Then the asterisk -r screen shows these error after every call:

NOTICE[32006][C-00000024]: chan_sip.c:30854 sip_request_call: Conflicting extension values given. Using ‘+9772359####’ and not ‘9843######’
WARNING[2706][C-00000024]: chan_sip.c:24305 handle_response_invite: Received response: “Forbidden” from ‘<sip:9003 @10.59.249.6>;tag=as149f21b2’
WARNING[32006][C-00000024]: channel.c:4864 ast_prod: Prodding channel ‘SIP/9003-0000003a’ failed
NOTICE[32024][C-00000025]: chan_sip.c:30854 sip_request_call: Conflicting extension values given. Using ‘+9772359####’ and not ‘9843######’
WARNING[2706][C-00000025]: chan_sip.c:24305 handle_response_invite: Received response: “Forbidden” from ‘<sip:9003@ 10.59.249.6>;tag=as4abd4511’
WARNING[32024][C-00000025]: channel.c:4864 ast_prod: Prodding channel ‘SIP/9003-0000003c’ failed

I am dialling a correct number and also there is the outbound route configured with dial plans. I am also confused over the error "Conflicting extension given. and it’s using the SIP’s CID.

I have pasted the SIP debug info in Pastebin link: https:// pastebin . com/p7PgvE6J
##Cannot post links. That shows how newbie I am!!##


#2

On line 446 of your paste, the provider rejected the call:
Warning: 399 03077.08866.A.005.403.228.0.6.02248.00000000.1075445762 "Invalid User"
FreePBX was trying to send your extension number 9003 as caller ID in the From header; the provider expected a username.

In the trunk settings PEER details (and also USER details if that section is not blank), add
fromuser=xxxx
(replace xxxx with the same username as in your Register String).

If that doesn’t let you get past the 403 error, also add
fromdomain=ims.ntc.net.np

But there is another problem: You are trying to call your mobile but Asterisk substituted +97723597002 (I’m guessing this is the Bhadrapur number NTC assigned you). You probably have this number in the host field or somewhere else where it doesn’t belong.

If you still have trouble, post screenshots of the trunk configuration (particularly the Outgoing tab), as well as another log. Please don’t set an expiration on anything related to your thread – someone reading this next year may be helped by viewing the pastes, external images, etc.


(Lemillion) #3

Thank You for your reply and help! I added both fromuser and fromdomain but am still getting the same issue!

This +9772359XXXX is cid number and username provided to me!

I cannot post a screenshot as a new user. So here is my config below:

Trunk Name: +9772359XXXX@ims.ntc.net.np
Peer Details:
type=peer
host=ims.ntc.net.np
defaultuser=+9772359XXXX@ims.ntc.net.np
remotesecret=password
fromuser=+9772359XXXX
fromdomain=ims.ntc.net.np
usereqphone=yes
disallow=all
allow=alaw,ulaw,g722,g729
dtmfmode=auto
outboundproxy=10.40.45.4:5060
context=from-trunk
transport=udp
qualify=yes

Register String: +9772359XXXX:password:+9772359XXXX@ims.ntc.net.np@ims.ntc.net.np/2359XXXX

Also, please find the new logs. I will be setting expiration to Never. Thank You for mentioning the fact! New logs >> https:// pastebin .com/JvWEnaPJ


(Lemillion) #4

Also I am getting these error after “core restart now” command! is it related?

WARNING[12018][C-00000001]: app_macro.c:274 _macro_exec: Macro() is deprecated and will be removed from a future version of Asterisk.
WARNING[12018][C-00000001]: app_macro.c:275 _macro_exec: Dialplan should be updated to use Gosub instead.

(Lemillion) #5

Thank You for mentioning this! I just changed my trunk name to NTC and it’s working!! Never felt this excited after getting a call! Thank You again!


#6

It is “deprecated” that does not mean it doesn’t still work (at this point in time).

FreePBX currently still relies on app_macro, if you build asterisk ‘off the reservation’ you will need to enable app_macro in the makemenu bit

(It is,(for me at least) interesting that Asterisk and FreePBX are now under the same ‘big tent’ for a while now, but this contretemps remains :wink: )


(Lemillion) #7

@dicko Thank You for making it clear! I am new to this but will be learning it for sure!


#8

Glad to hear that you got it working. A somewhat off-topic question for you:

In 1989, I was living in San Francisco and took a trek around Annapurna. My only communication device was a small shortwave receiver. When I turned it on to hear the score of the World Series game, I learned that the game had been canceled because of a major earthquake. Though few deaths were reported, I wanted to call home to see if any family or friends were hurt. However, I was three days’ walk from the nearest phone and decided to continue on the trek. Upon reaching Pokhara, I called and was delighted to learn that everyone was ok.

On that route today, is there cellular coverage most of the way? If not, how far might one be from a working mobile or landline phone? Do trekkers typically carry satellite phones?


(Lemillion) #9

WOW! Nice to hear that you were here! I was not even born at that time! :smile: But yes there is mobile phone coverage in almost every major trekking routes, but due to uneven terrain, there are few places with poor reception and no signal.

Landlines are available in almost every places nowadays. 4G is available too in several major cities like Pokhara and Kathmandu. You can only find 2g and 3g in trekking routes but internet connectivity is a problem in remote areas. There’s no need to carry satellite phone; unless you prefer it the most! And VOIP is very new here with very few people being able to configure it!


(Lemillion) #10

Hello Stewart, I was hoping if you could help me out in this thread: https:// community .freepbx.org/t/inbound-and-outbound-is-working-but-is-not-audible-on-both-sides/69295?u=lemillion. :slight_smile:


(David Johnson) #11

Quick short note to all. I have had this issue myself and a recent change in the laws (US?) and my SIP provider, you can NOT make any outbound calls unless the extension has caller ID set (or forced on the trunk). I was getting a busy (or a message no available trunks) depending on the carrier after dialing an external number. Adding a CID to the extension fixed this immediately. I noticed this started happening after a recent law change . Just make sure you have Caller ID set to be sure thats not your problem especially if everything else works fine.


(system) closed #12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.