Incoming Call Issue from NetGen ATA

siptrunk
configuration
Tags: #<Tag:0x00007f7036c69050> #<Tag:0x00007f7036c68f10>

(Jason) #1

Hi!
I’m a former Nortel Option 81C Admin who is spending his newfound COVID time hobbying with building a telephony server using spare parts. I am now building and moving to FreePBX from 3CX using mostly the same equipment (3CX is on a RasPi and FreePBX an HP EliteDesk). I have an off-brand 2FXO 2 FXS ATA that has one PSTN connected to an FXO (Trunk 10000 in FPBX) and both FXS are in use (Ext 101 & 201). Using the current config, I managed to get it to work flawlessly with 3CX, which is much less flexible (one of the reasons I am moving away). However, with FreePBX incoming calls get “answered” and immediately dropped. I can make outgoing calls.

I’ve attached select logs from FPBX and the ATA:

It appears it’s not authorizing? This is where I’m getting lost - the two FXS ports are authorizing fine and I can receive incoming calls .

Here are my PJSIP settings for this trunk:
Username = Username is trunk name
Secret =
Authentication = Both (Tried Outbound)
Registration = Recieve
Language Code = Default
SIP Server = 10.172.20.5
SIP Server Port = 5060
Context = from-pstn
Transport = 0.0.0.0-udp

As a side note, I have two GV lines coming in via an ObiTalk Device - those work flawlessly.

Thanks for any help or insight you can give this noob!


(Jason) #2

So after some trial and error, I got it to accept incoming calls by enabling “anonymous calls” in SIP settings. This is not ideal, for security purposes. Any thoughts on how to resolve with “anonymous calls” set to off?


Use Telco VM on POTS line
(Lorne Gaetz) #3

You’ve created a chan_sip trunk, but you’re sending the INVITE to the pjsip port. Either create a pjsip trunk for the calls (preferred), or fix the port config on the ATA device.


(Jason) #4

Thanks for responding!
That was my thought too. It is created as a pjsip trunk.

Any other thoughts?