Inbound Calls Dropping - need assistance


after i migrated to a new firewall model calls get dropped after about 30 sec.
i am not sure from where the issue is,i run test in firewall that nat is geeting to the voip server.
i am not sure from where the issue is.

from my fw: didnt see ay drops

i cant uploaded logs or put link to freepbx as forusm doesnt allow to upload for new users which is funny

assistance would be appreciated

You can upload them to a pastebin server. Preferably, and post the URL or the last part of it. (You can also post the full URL as pre-formatted text.)

Blocking new users from uploading images is not unusual, as inappropriate images can put site operators into quite difficult legal positions.

The most likely causes of your problem is that you have not specified the correct external address, or that the remote side is behind NAT and isn’t giving the correct contact address, and you haven’t enable rewrite contact to compensate.


here is last part of pastebin url: 08d139c1

hope that i can understand why calls getting dropped.

note: : voip provider ip server my freepbx ip
my wan ip: start with 79.178

You’ve screen scraped this, rather than used the log files, which means there is a lack of timing information. However that log shows a call cleanly terminated by the Linksys. Did the callee receive any audio?

Note you are using a version of Asterisk that is no longer supported, and, although it still has about 3 months of security fixes left, you have not applied the latest security fix.


thx for checking,

another log: d24299d3

yes there is voice on both ends. but call get disconnected after about 30 seconds.

can you tell me what in the log file proof that something in my FW drop the connection?

by the way linksys is my spa phone adapter at ip :

I can tell that something claiming to be a Linksys/SPA3000-3.1.10(GWd) dropped it. If that is your router, you need to disable SIP ALG in it. This is on the outbound leg.

<--- SIP read from UDP: --->
BYE sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK-d1d3eb44
From: <sip:[email protected]:5060>;tag=84d61e9ace1b42i0
To: "+972507666244" <sip:[email protected]>;tag=as27cd9afb
Call-ID: [email protected]:5060
CSeq: 101 BYE
Max-Forwards: 70
User-Agent: Linksys/SPA3000-3.1.10(GWd)
Content-Length: 0

The SPA3000 is an ATA Configure SPA3000 as SIP Trunk | FreePBX 13 (PJSIP) - FreePBX OpenSource Project - Documentation I suspect there is something miss configured on that end.

Do you have the correct external/internal network IPs configured under Settings → Asterisk SIP Settings?

I couldn’t see any NAT issues in the trace.

I don’t think there is any NAT actually. The PBX and the ATA are on the same subnet.

i checked all what you said, but still we didnt advance.

i didnt find on linksys spa 3000 to disable sip alg, but i disabled sip alg in my firewall.
i went through configuration of spa 3000 and everything is configured well.
under Asterisk SIP Settings i have the correct external ip and correct internal networks.

please suggest how do i advance from here i need to know from where is the issue, if yu need further screenshots or logs please let me know.

i went through still having this issue, can you let me know if i need to run any command or any screenshots you need to check.

i really need this solved -__–

I really don’t know anything about these devices. You could follow the instructions in the Wiki that I already linked up higher.

Is this issue related to the SPA3000? To test, temporarily route the incoming call to another local extension (IP phone, softphone, etc.).

Is this issue related to the Zadarma trunk? To test, call extension 2000 from another local extension.

Disable SIP ALG was based on your correctly identifying the Linksys device, in the logs, as being a router. I thought it probably wasn’t, which I gave the full identity and said “if it is your router”.

This log doesn’t include the start of the call, so I can’t tell how many seconds into the call the BYE was received.

when i am using sip client in my phone it doesnt disconnect. i configured both internal ip of freepbx and external and it is working.

so i am not sure from where call get disconnected from linksys spa adapter or from firewall.
as in firewall we didnt see any drops.

so still i do not know who cause the issue

When you call from the SIP client (connected via Wi-Fi with an IP address in the same subnet as the PBX) to the SPA3000, does the call still drop?


check this log: ccadb7f7

  • i really want to know who is causing the issue and how to solve this, if you need any screenshots or configuration let me know and i will provide.

  • this is my udp timeout setting in firewall should it be changed?
    udp timeout: 30
    udp timeout stream: 150

hope we can know what cause the dropping of the call.

The UDP timeouts are orders of magnitude too small, but they wouldn’t cause the call to be cleanly terminated, but rather for one end to end up repeatedly retransmitting and not reahing the other. It is best not to rely on timeouts, and to use locked down port forwarding rules.

Just noticed that you are getting retransmissions, in the latest log.