Inbound Calls Dropping - need assistance

see the logs i posted maybe you can see something that indicate who cause the issue.

i just have 1 extension and it is connected to my isp voip provider. i have phone connected to linksys spa3000 in line1. so when once i configure this extension in my sip software in mobile phone then now this software on my mobile is receiving the call and it doesnt disconnect.
i have to disable this connection so i can receive phone call on spa300 on my home phone.

any ideas?

port forwarding is configured to freepbx from wan, and today i checked and we didnt see any drops when i make calls, so i am not sure if the firewall is causing this or not.

any suggestion what to do next?

The call was answered at 13:26:20 and the SPA sent a BYE only 16 seconds later. During this time, did you have good audio in both directions? If not, provide details. What did the SPA user hear after the call dropped (dial tone, busy signal, silence, etc.)?

Please create another, e.g. 2001 and register the SIP app to that. Then dial 2000 from 2001 and report whether the call works correctly and stays up.

I did ask that, or rather the inbound direction, as it is the callee that dropped the call, and would therefore be the one that would be detecting lack of media, if that was the problem. The OP said it was OK.

yes i could hear on both sides.

i confiigured both two extensions 2000 and 2001 in sip software on mobile, both are connected and i could dial external numbers without issues. but when i try to dial extension number for example 2001 it says all extnensions are taken try to call later. then i see on the screen service unvailable.

on extensions in freepbx > on advanced> dial > it says: SIP/2001
so this is how i type in my sip software to dial to the extension but it doesnt work. i also
typed 2021, same results…

what should i do?

From extension 2001, call
You should hear “Your extension number is two zero zero one.”

Then, from extension 2000, call
If the call fails, please paste the Asterisk log for the call at and post the link here.


yes i dialed *65 and i heard my extension.

i installed sip software in my machine then configured 2000 extension. then called 2001 extension without issues.

what our next step, and does this test tell us where the issue is? or we need further tests.
i am also in contact with my fw team anything in particular i i should tell them to check?
what regarding the spa3000 i dont know how to check if it is the issue or not…

hello there,

my fw guys checked logs checked the fw log, can you please check and answer , pastebin: 14149ab2

1- do i have to open any rules from outside to my spa3000 adapter sip trunk?
currently my dnat rule from outside is getting towards my freepbx server at port 5060
do we need to forward the traffic from wan to spa3000 sip trunk first? and then spa3000 will forward traffic to freepbx

2- does sip trunk make any changes in sip traffic? or just forward traffic to freepbx

3- you asked: Is this issue related to the SPA3000? To test, temporarily route the incoming call to another local extension (IP phone, softphone, etc.).

  • i installed sip software in my machine then configured 2000 extension. then called 2001 extension which was configured on sip software on my mobile without issues.
    Does that confirm that issue is not from spa3000 ?

4- which device is sending traffic to my sip provider is it spa3000 or freepbx?

5- after checking logs . is it normal that rtp channel is getting in the spa300 , shouldnt we see in the logs that it is done in freepbpx

6- another thing in the log we see this 2 changes which is not clear:
To: From:
and why there is another communication like that To: ( sip provider ip )
From: 14361
why there is 2 channels established for 1 connection when i dial ?
according to my fw guys this might suggest why call is getting dropped.

waiting for your answers so i can get back to them to my FW guys who are waiting for the answers.


No. The SPA ‘talks’ only to the PBX and the PBX talks to the outside as needed.

It shouldn’t, provided that Direct Media is off (the default case), traffic from SPA is only to/from the PBX.

Please confirm that at the time of your test, the SPA was shut down. You called in from the outside, extension 2000 (the softphone) rang, you answered it, there was good audio in both directions and the call stayed up for at least a minute.

Only the PBX. Your provider should not be able to even see that there is an SPA in the system.

Normal operation is that the PBX relays traffic. Voice from the provider to PBX, PBX sends it to SPA. Voice from SPA to PBX, PBX sends it to provider. There are many reasons for this (transcode if needed, encrypt/decrypt if needed, record or monitor the call, listen for in-call DTMF, etc.) If you don’t need any of those, it is possible to bypass the relay and have the SPA talk to the provider directly, but that is a very advanced setup and you shouldn’t even think about it until the normal setup is working perfectly.

In addition to confirming whether or not external incoming calls drop when routed to a softphone, also confirm whether or not an internal call from a softphone to the SPA drops. From there, we can set up an appropriate test and log it.

hello there,

installed sip phone software on my pc then made the tests as you requested.

spa3000 device = on
called my external phone number > TO pc softphone ext:2000 answered > works well.

spa3000 device = off
called my exteral phone number > TO pc softphone ext:2000 answered > works well.

internal call from a softphone To spa:
called from sofphone 2001 > to 2000 ext spa phone line > works i can hear both side, but disconnects after
about 20 seconds

i tried also to make phone calls from phone line spa to > external numbers or call extension 2001 to softphone doesnt work at all.

how do i fix this?

Looking forward your reply


i made the tests can you let me know what should i do next or what might be issue now ?

internal call from a softphone To spa:
called from sofphone 2001 > to 2000 ext spa phone line > works i can hear both side, but disconnects after
about 20 seconds

i tried also to make phone calls from phone line spa to > external numbers or call extension 2001 to softphone doesnt work at all. altough i dont need to call outside from phone line 2000, but i just made this for test purpose.

let me know whats the step, i am also in touch with my fw guys should we check anything in particular or configure any setting for spa3000 in firewall?
what the next step

If I understand your setup correctly, the SPA, PBX and test softphone are all on the same LAN subnet, so your failing 2001 > 2000 test should not have any traffic (SIP or voice) passing through the firewall. This would mean that the problem is unrelated to the firewall. Your IT guys should be able to confirm.

What is the make/model of the device connected to the Line 1 port of the SPA? If it’s something complex, there might be a compatibility issue. Do you have a simple line-powered corded phone to test with (one that does not connect to AC power and does not use batteries)?

I don’t have an SPA3000 but do have an SPA3102, which I believe is very similar. On the System tab, set up both Syslog Server and Debug Server to the address of your PC (or someplace else to capture syslog information). Set Debug Level to 3 and on the Line 1 tab, set SIP Debug Option to full. Set up your syslog server (or you can just run Wireshark and set the display filter to syslog). Make a failing call from 2001 to 2000. When the call drops, you should see the BYE being set by the SPA. With luck, whatever you see just before that should be a clue as to why the SPA dropped the call.

For the outbound call issue, check that the Dial Plan setting on the Line 1 tab matches the number you are trying to call. For testing, try setting it to
Call *43 (echo test). If that works, call 2001. Report whether the calls drop.

Are you using the FXO side of the SPA? If so, what do you have connected there and is it working properly?


pastebin: b5479e1d and: 26b19965
please check i enable logging in spa3000 to syslog server. called from my siphone-soft ext2001
To spa3000 which i have a phone connected in line 1.

yes spa3000 and pbx same network.i just checked with FW guys they confrmed no traffic was blocked
when we checked logged once i intiated a call. so it seems now that i have a local issue to solve with spa3000.

for outband call done what you asked,
called from my phone connected to spa ext 2000 To ext 2001 - call drops pastebin: de207e1b

called my phone connected to spa ext 2000 to my external mobile phone number - call drops same after 20 sec or so. pastebin: aeee6fe5

does the log says why the call drop locally?

Line 152 shows that the SPA saw the phone go back on hook (hung up), even though you presumably didn’t actually hang it up.

One possibility is a hardware issue. With luck it’s just the power adapter; try another if you have one with the correct voltage, a compatible plug with correct polarity and a current rating equal or greater to the original.

Possibly, compatibility with the connected device. Do you have another phone to try, using a different cord?

If none of the above, the SPA is likely defective.

Same issue with the outbound call. Device saw hangup on line 85.


lol. I cant believe it. it is a cordless phone, i replaced the handset to another one and i got no issues now!
thanks for the assistance stewart for leading me to solution and good troubleshooting, also thanks to david.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.