Inbound calls drop after 30 seconds

Hello everyone. I’ve seen the “calls dropped after 30 seconds” problem all over the place on older posts in this forum and on other forums using asterisk-based PBXs. I’m experiencing the same thing. It looks like the issue is firewall based or NAT based in most cases. I tried port forwarding port 5060 on my FreePBX local IP address through my router as well. I also tried an inbound call with both the PBX and router firewalls disabled and the call still cut off after 30 seconds.

Nothing seems to be working.

Edit: I have also gone into SIP settings and made sure my external IP address has been updated. My ISP issued me a new public IP address recently but FreePBX shows that it is using the new one.

Here’s a log for a call:

Edit: Without any real eivdence, it seems like this is a NAT issue. I’ve done everything I can think of and read about. I’ve disabled SIP passthrough on my router, forwarded SIP, RTP, and IAX ports on my router, and checked the NAT settings on FreePBX. This is really disrupting my business because inbound callers essentially cannot call me.

I’m not sure what port you are using… default PJSIP is 5160, not 5060.
You also need to forward ports 10000-20000

Also, you did not say what router/firewall you are using, that’s a helpful tip.

It turned out being that when my ISP gave me a new public IP address some settings didn’t automatically change in FreePBX. I updated the address in a couple of places and it started working again.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.