If I choose to return a call from History on phone, it is always busy

However, if I manually dial the same number, it rings as expected.

I tried this, did not help:

“Remove + from caller ID”

Thanks in advance

Logs are usually the way we’d solve this. An extract of /var/log/asterisk/full around the failed call will tell us what the issue is.

It’s probably going to be a misconfigured outbound route, but the logs will tell us for sure.

If it did nothing, then you didn’t set the context correctly, didn’t apply changes, or have a subtle issue with your trunk best resolved by posting a log as noted by @cynjut .

If it changed the number to 4445551212 (as it should) but your Outbound Routes don’t permit that format, then either change them to allow 10-digit dialing, or create a custom context that removes only the +.

chan_sip.c: Call from ‘116’ ( to extension ‘+15125671234’ rejected because extension not found in context ‘from-internal’.

I don’t understand your post. Are you saying that when you followed the “remove + from …” instructions, the incoming caller ID still showed the +? Or, are you returning a call from ‘old’ history (before you made the change)? If the latter, that is not expected to work. Only the ‘new’ history is fixed.

If you wish, you can also set up an additional pattern in your Outbound Route with + in the prefix and the same match pattern (e.g. 1NXXNXXXXXX) so the initial + will be accepted.

I tried earlier, I removed the + successfully, so history showed the 10 digit number, based on the detail in the post I mentioned originally. The + was gone. I tried to dial a new history, still busy.

When that still went directly to busy, I set it back since I don’t want to make too many changes during their workday.

This log info is for as it is now, and as it was originally. My outgoing call pattern is: 1NXXNXXXXXX

So I will try adding + in the prefix in the outgoing call pattern, little later today.

I made this change, same exact error message in log file:

This log info is for as it is now, and as it was originally. My outgoing call pattern is: 1NXXNXXXXXX

So I added + in the prefix in the outgoing call pattern, same issue.

OOPS - though I submitted and applied, the outgoing call pattern did not save. Let me try again.

NOPE, it will not save that pattern in OutBound Route call pattern

I don’t understand why that didn’t work, but it may be easiest for you to strip the +1 and also allow 10-digit dialing by setting up an Outbound Route pattern with:
prepend: 1
match pattern: NXXNXXXXXX
prefix: (blank)

That will permit users to dial 10 digits as well as 11.

(I assume that you are dialing 011 prefix for international.)

Fixed, thanks!

The reason it did not work is that I am an idiot. Though you clearly said ‘with + in the prefix’, and I responded that I did so, I did not, I added the + as a prepend.

Once I realized that, and followed your instructions, it worked. Seriously Stewart, thank you.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.