IAX trunk between sites - FreePBX HA [Solved]


I’ve been working on getting IAX Trunks working for a while now and am having some issues. My goal is to bring up IAX and DUNDi trunks so I can inform each PBX about the others exensions. If there is a better way, please let me know. :slight_smile:

The sites are connected via VPN.

site1 contains 2 Sangoma 300 Appliances in HA mode, so there is a floating IP. Sites 2 and 3 each have 1 Sangoma 100 Appliance.

Configuration is something like this:

site1 floating IP.
site1 FreePBX-ha01 IP
site1 FreePBX-ha02 IP

site2 FreePBX1 IP

site3 FreePBX1. IP

in the log in site two, I see this over and over:

2017-09-08 22:19:20] NOTICE[2271] dnsmgr.c: dnssrv: host ‘01.voice.com’ changed from to
[2017-09-08 22:19:20] NOTICE[2271] dnsmgr.c: dnssrv: host ‘01.voice.com’ changed from to

In DNS, “01.voice.com” is a single A Record pointing 10 the floating IP:

In a Packet Capture I am seeing this:

-9:-5:-41.549905 IP > UDP, length 14
-9:-5:-41.550537 IP > UDP, length 12
-9:-4:-58.335394 IP > UDP, length 14

It makes me wonder if there is something special I am missing with the HA setup. Should I be pointing the trunk at the ‘real’ IP? If so, does that mean I need multiple trunks for each HA participant?

Thank you!!!

You need to bind IAX to the floating ip the same way you did for SIP.

1 Like

Of course its that easy! :slight_smile: I should have asked a week ago.

Adding the floating IP to Settings > Asterisk IAX Settings > Advanced > Bind Address on the HA cluster worked. I did have to reboot (perhaps a network restart would have worked?), but just applying the settings isn’t enough. I rebooted both endpoints and the trunk came up fine on both sides, with two way audio on test calls.

Thank you @lgaetz !



For future, a reboot isn’t necessary. Just restart Asterisk with fwconsole restart.