HT813 FXS Port works but FXO keep getting 403


(Last Dayz) #1

Hello,
I`m adding an FXS/FXO Gateway as a trunk to my PBX.
I have configured FXS port on HT813 without a problem, works inbound and out.

But FXO port keeps sending me 403 for unknown reason, I have tried with registration (host=dynamic) the gate registeres just fine but returns 403.
My preffered method is IP auth and when setting the host ip I get the same issue 403 forbidden.

This is my FXO trunk config on PBX
type=peer
username=026821080
secret=sifra123
host=10.10.12.99
port=5062
context=from-trunk
dtmfmode=rfc2833
allow=alaw,ulaw

Here are the SIP traces

At this point Im clueless whats wrong.


#2

In the HT, make sure that Stage Method is set to 1 and Wait for Dial Tone is set to No.

If you still have trouble, at the Asterisk command prompt type
sip set debug on
make a failing test call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here. If you are too new to post links, just post the last 8 hex characters of the URL.


(Last Dayz) #3

<— SIP read from UDP:10.10.12.99:5062 —>
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 10.10.12.101:5060;branch=z9hG4bK7fc6e870
From: sip:026821080@10.10.12.101;tag=as5c65eedb
To: sip:95063442323@10.10.12.99:5062
Call-ID: 2d7da5560fc6f56425fffdef3b2c5ca0@10.10.12.101:5060
CSeq: 102 INVITE
Supported: replaces, path, timer, eventlist
User-Agent: Grandstream HT813 1.0.13.3
Allow: INVITE, ACK, OPTIONS, CANCEL, BYE, SUBSCRIBE, NOTIFY, INFO, REFER, UPDATE
Content-Length: 0

<------------->
— (10 headers 0 lines) —

<— SIP read from UDP:10.10.12.99:5062 —>
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 10.10.12.101:5060;branch=z9hG4bK7fc6e870
From: sip:026821080@10.10.12.101;tag=as5c65eedb
To: sip:95063442323@10.10.12.99:5062;tag=1805100478
Call-ID: 2d7da5560fc6f56425fffdef3b2c5ca0@10.10.12.101:5060
CSeq: 102 INVITE
Supported: replaces, path, timer, eventlist
User-Agent: Grandstream HT813 1.0.13.3
Allow: INVITE, ACK, OPTIONS, CANCEL, BYE, SUBSCRIBE, NOTIFY, INFO, REFER, UPDATE
Content-Length: 0

<------------->
— (10 headers 0 lines) —
Transmitting (no NAT) to 10.10.12.99:5062:
ACK sip:95063442323@10.10.12.99:5062 SIP/2.0
Via: SIP/2.0/UDP 10.10.12.101:5060;branch=z9hG4bK7fc6e870
Max-Forwards: 70
From: sip:026821080@10.10.12.101;tag=as5c65eedb
To: sip:95063442323@10.10.12.99:5062;tag=1805100478
Contact: sip:026821080@10.10.12.101:5060
Call-ID: 2d7da5560fc6f56425fffdef3b2c5ca0@10.10.12.101:5060
CSeq: 102 ACK
User-Agent: FPBX-15.0.17.37(16.13.0)
Content-Length: 0


(David55) #4

The trace is incomplete: it doesn’t include the INVITE, and you didn’t use pastebin.


#5

What country are you in? I’m not aware of any place where 95063442323 is a valid number to dial on a POTS line.

What is the FXO connected to (copper pair from central office, cable MTA, fiber ONT, another PBX)?

What does the HT Status page show for the FXO port?

Do incoming calls work correctly?


(Last Dayz) #6

Sorry guys, here`s the complete trace

Im in Serbia for the initial trace Ive pasted I found an option on HT813 for PSTN out dial code (pic below)

So I was checking out will it work, but no matter what I send to HT813 I get the same 403.

HT status Page shows
FXO Idle 026821080 Not Registered

If i switch to Registrations options and define trunk on pbx to register It shows
FXO Idle 026821080 Registered

But nevertheless It rejects with 403 any calls sent to it

For the moment I don’t have option to test inbound calls to FXO port but I` have tested the line with an actual phone, works all right.
Connected to copper pair from the CO


#7

Please post screenshots of all FXO page settings.


(Last Dayz) #8

Here it is


#9

Please set Wait for Dial Tone to No and set Stage Method to 1. Retest. If you still have trouble, paste another log.


(Last Dayz) #10

It`s working!
Thank you very much sir!


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.