How to upgrade freepbx 16 to bookworm

Hi. I have freepbx 16 up to date, and now that bookworm has been released, I would like to update to bookworm. I am using bullseye at the moment.

Any assistance would be appreciated.

I don’t think that is possible, otherwise than as a custom install, as I believe that Asterisk has been dropped from Bookworm, as it was too difficult to maintain.

See Status and perspectives of asterisk package on Debian Bookworm - Asterisk Distributions - Asterisk Community

You can upgrade to bookend quite simply , if you installed asterisk by the deb package I suggest you first get the source of the preferred asterisk then

apt remove asterisk*
./configure --with-jannsson-bundled
make menuselect# make sire you app macro selected
make install 

deleting any module in /usr/lib/asterisk/modiles that it complains about, that should remove any OS dependencies , then upgrade debian


Thanks for the hint – I get asterisk from git anyway, I was primarily worried about whether bookworm had incompatible versions of things that would break freepbx.

Thanks again.

No, bookworm has php7.4 but you would need to downgrade node to version 8 to get pm2 working I needed

node -v
npm install -g n
n list
n install 8
n list
n rm (anything but  what you just installed)
hash -r

hmmm, I have node v 12.22.5 and the system works in preliminary testing under bullseye. What is janson? I am not seeing it anywhere on my current system.



libjannson is a chan_pjsip pre-requisite but if you ran the contrib/install-prereq script you probably won’t need ‘bundled’

fwconsole pm2 --list

OK, still using chan_sip, probably that’s why I don’t see jannson. Will check this all out.

So, you want cutting edge OS but still rely on a long deprecated SIP channel, why ?


Well, I have learned the pjsip configs, so I have upgraded yet. I have been concentrated on upgrading to confbridge which is not working for me. Confbridge does not display as much information as meetme did and I was trying to fix, but no luck so far.

please don’t conflate your problems, we generally moved to confbridge 8 years ago for reasons of efficiency , so what version of FreePBX/ Asterisk are you currently using that still prefers meetme ?

You can still prefer meetme over confbridge in advanced settings if you have the module built and installed

I am using 18.13.0-rc1. I know that meetme will go away soon, that I was trying to upgrade to confbridge. After that is done, I will upgrade to pjsip.

Then be careful to not put the cart before the horse, 18 still has meetme, your last priority should be your OS because Asterisk really doesn’t care and there is no advantage to you.

…and why are you using an Asterisk 18 release candidate from a year ago

1 Like

This system is in development, before it goes live, of course I will upgrade asterisk 18 to its latest version. Thanks for the reminder.

So, I understand that php 7.4 is past the end of life – how should I proceed with freepbx – do I need to keep php 7.4 or something else I should do?


Tell us a bit about your application. FreePBX was designed to have the ‘whole machine’. If you just have a few custom scripts, I would run the Distro and call it a day. You won’t have to worry about versions of OS, subsystems or libraries, just like you probably aren’t concerned about what OS your refrigerator or TV set is using.

OTOH, if you are trying to run a big project such as a CRM system or predictive dialer in the same image, IMO that is asking for trouble. Run these systems in separate VMs and have them communicate over the network.

I am just using freepbx as a pbx and I wanted to make sure it would still work when I upgraded the php to 8.2 or whatever it is now. If that works, I will just go ahead.

Why are you needing to update PHP on the machine that’s running your PBX? Are you using the FreePBX distro that Sangoma is providing? If so then you don’t have to worry about doing any updates/migrations to any of the subsystems, that’s all handled by Sangoma automatically.

I am using freepbx 16 originally installed under Bullseye and I just want to make sure that things will work under newer versions of php since I have heard on other forums that php 7.4 is about eol. I hope that is clear.