How to setup reliance JIO trunk (SIP provider in INDIA)

siptrunk
Tags: #<Tag:0x00007fafc24f6fe0>

(Lal) #1

Hi,
Dear Community Team members,
How to configure reliance JIO SIP trunk (provider in india)
They are provide following information;
Signal IP: 10.1.1.5
Media IP: 10.1.1.6
Pilat Number: 9999999944
DID Range: 9999999942-43 and 9999999945-65
Username & password is not required

how to setup a sip trunk with the above information, Please find the connectivity diagram
Please suggest a solution (Is there any help doc?)


(Andreas Keller) #2

Hi Lal

create a pjsip trunk - pjsip settings
Authentication = none
Registration = none
SIP Server = 10.1.1.5
SIP Server Port = 5060

#Advanced
From Domain: = 10.0.0.1

#Codecs
include alaw

Help for dial pattern: https://wiki.freepbx.org/display/PHON/Dial+Patterns

Andi


(Lal) #3

Thank you for your reply,
Few minutes back I had configured chan_SIP trunk.
Now all outgoing calls working perfectly, but all incoming calls are respond “all circuits are busy”
My trunk config as follows;

transport=udp
host=XXXXX
fromdomain=XXXXXXXXXXX
username=XXXXXXXXX
secret=XXXXXXXXX
insecure=very
context=from-internal
type=friend
promiscredir=yes
qualify=yes
canreinvite=yes


(Lal) #4

transport=udp
host=XXXXX
fromdomain=XXXXXXXXXXX
username=XXXXXXXXX
secret=XXXXXXXXX
insecure=very
context=from-internal
type=friend
promiscredir=yes
qualify=yes
canreinvite=yes

These configurations are given in Chan_SIP Trunk --> SIP setting Tab–> Outgoing --> Peer details

Incoming tab currently blank. Is there any config required?


(Lorne Gaetz) #5

Looks like this trunk doesn’t use registration, so you must ensure that inbound calls are being sent to the chan_sip port.


(Andreas Keller) #6

why you include secret? As my understanding is, that there is no authentication required.

context from-internal ?

nerveless, disable this trunk and add a pjsip trunk as I recommended. Give pjsip a try!

Andi


(Lal) #7

That update now only given by My provider. i will try and update you


(Lal) #8

Thanks for your reply,
I had configured PJSIP Trunk. Outgoing calls working fine,
incoming calls are connected without audio.

What should I do for getting audio in incoming calls?


(Andreas Keller) #9

seems to me NAT / routing problems.

Can you send a log of a incoming call?

Can you tell me more about your Chan PJSIP settings? (Settings - Asterisk SIP settings)


(Lal) #10

Yes it maybe a NAT issue,
Please find the attached Chan pjsip setting



(Andreas Keller) #11

have you entered the 10.0.0.0/30 ? (Local Networks)

Why 5065 ?


(Lal) #12

yes entered 10.0.0.0 as local network, its entered by click on detect network settings button.

5060 port is used by client iphones (chansip), that why i set this 5065 port here.
pls give me a suggestion for correcting this.


(Andreas Keller) #13

Need trace of a incoming call.

Console
asterisk - r
core set verbose 9

Make a call


(Lal) #14

Thank you for your valuable suggestions. Both incoming and outgoing calls are working now.
The issue (incoming calls) was due to mistakenly configured wan ip in asterisk NAT settings.


(system) closed #15

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.