How to make Sangoma Connect mobile work?!

Hi guys,

I cannot solve this myself!!

I’m trailing Sangoma Connect mobile app. It won’t register over my WLAN.

It never registers successfully. I’ve seen times when it registered over cellular network, but even that is spotty. I attribute this to my crappy tower signal. So, it might mean I have a network issue or setting misconfigured.

Additionally,

What ports does it require to open on the WAN facing firewall?

It only seemed to work over cellular line after I added these IPs on my WAN facing firewall:

107.170.65.67

107.170.123.70

107.170.151.176

159.65.186.176

159.65.251.173

159.65.252.186

159.65.253.49

162.243.35.55

162.243.66.221

162.243.226.67

162.243.226.164

165.227.184.188

167.99.48.91

167.99.119.203

167.99.119.244

192.241.179.113

Here are module settings:

Responsive firewall:

SIP packet flow when dialed from IP phone to the extension added in SC:



So, let me know what else you want me to post to find a root cause.

Thanks!

Wiki pages for Connect are here Sangoma Connect Mobile - Sangoma Connect - Documentation

Thank you Lorne. I followed it last night, but registration doesn’t work at the end over LAN.
It even registered mobile device in the module. I could use it over the cell line only.

My PBX setup is pretty basic.

However, mobile device is usually seats on the different VLAN from PBX. But both VLAN’s are fully accessible and I can ping ether direction OK.

So you have already read this page: Technical Details - Sangoma Connect - Documentation
which states in part

Sangoma Connect is provisioned to register only to a single FQDN (or IP) which can be set by the PBX administrator. Support for dual registration (i.e LAN/WAN or or auto failover) must be accomplished using DNS.

Have you configured Connect using an FQDN and do you have local DNS setup so LAN devices will resolve to the LAN ip of the pbx?

I saw that part actually. But confused which DNS it talking about.

I have DNS record locally where phone seats, ex: if I ping say fpbx it returns its LAN IP.

I also put DDNS address into registration address field on the module, see screenshot:

Does this work?
If not, where should I configure DNS?

This is not a PBX setting. Connect mobile would need to be configured with an FQDN that resolves to the public IP of the PBX for the push services, and resolves to the LAN ip of the PBX for local registrations. Otherwise an FQDN that only resolves to the public IP of the PBX will work assuming you configure your router appropriately and that the service doesn’t have an issue with the hairpin.

Thank you for explaining. To further clarify on the network part.

If I query my DDNS address it happily resolves it to my public IP.

What additional settings do I put on my internet facing router?

Right now only 2 ports are open for external SIP trunk.

Bump for attention!
If someone could clarify on me what rules/DNS/routing I need to make LAN registration work.
Thanks.

Need to have the port for SIP, check in your Asterisk SIP Settings page what is your PJSIP UDP port (or TCP if that is what Connect is using, in Settings tab). On top of that, need the RTP port range, usually 10000-20000/UDP.

As I understand it, you would need to configure the router to accept your public address even when it arrives from the LAN side, and to still NAT it, in that case, and return it to the LAN.

I have those ports opened.
I use UDP for PJSIP
I have 5060 UDP and 10000-20000 UDP/TCP.

Instead of ‘hair-pinning ’ DNS at your router, you can add that "FQDN’ to /etc/hosts because linux will consult that source before going to the innertubes.

127.0.0.1 my.fqdn.com

I think it’s called NAT reflection?

In FreePBX?

No, in linux, edit (as root) /etc/hosts and add a line to have localhost provide resolution for your FQDN

Sorry, I meant in CentOS 7 of the FPBX?
Also, what is my FQDN in this case, my external DDNS address?

FreePBX is a set of software running under linux, your FQDN is your FullyQualifiedDomainName, DDNS will Fully Resolve that for remote connections, within your LAN you don’t need to ‘go ask’ because you already know where your PBX is :wink:
If you ping a DNS query to YOUR.FQDN.com it will return the external address of your Server, if you resolve with /etc/hosts it will returm 127.0.0.1, which as far as Linux is concerned, is essentially the same destination.

1 Like

Thanks Dicko, still confused on terms. I have LAN DNS record that points to FreePBX box.
Also, when I go to System Admin I see its hostname, I also have DDNS within FreePBX as well - not same one as I mentioned early.

So, which one do I use?

And lastly, 127.0.0.1 my.fqdn.com is it same place I see under System Admin - DNS?

Please expand on “I have LAN DNS record” , LAN’s rarely NEED to be Dynamic.

I can’t answer that I don’t use System Admin

I have an admin VLAN where I usually seat with PC, laptop and smart-phone. Now, PBX is physically on its own VLAN just for that purpose. So I can put http://fpbx/admin/ in browser and login, it’s only LAN.

I got commercial System Admin that has DNS thing, it has server list in it.