How to dial to a number with plus sign when I use PJSIP?

Dear All

First, I create a trunk named ‘+525595290002’. Then, I create a rule of outbound routes for the trunk ‘+525595290002’. The Dial Patterns is XXXXXXXX (8-digits).
So, when I make a phone call to 99999519 (8-digits), it may route to the trunk ‘+525595290002’. But I see the log said “Could not create dialog to endpoint ‘+525595290002’ as URI ‘+525595290002’ is not valid”.

log.tgz (2.2 KB)
I want to dial a number which contains a plus sign, like ‘+525595290002’. How can I do it? Thanks All!

Please refer to the log in the attachment.

I don’t think your problem is anything to do with the “+”. You’re talking about a SIP Trunk? Why name the trunk with a telephone number? Maybe that’s what confusing FreePBX or Asterisk. Try renaming the trunk to something alphanumeric, like: “[YourTrunkSupplierName]-Tr1”.

Maybe post screen grabs of the configuration pages for this Trunk?

Thanks for your reply!!
Actually, I just want to register a SIP account which the account name is ‘+525595290002’. and I want another SIP account can dial to this SIP account. What’s the procedure I need to do? Could you help me or give me some tips? I will try it and also reply the result. Thanks again!

Sorry - still cannot understand your problem.

Is the trunk successfully registering with your SIP provider? Please post screen grabs of the configuration pages for this trunk.

Please see the screenshots below. I want an extension account make a call with a trunk account which the account name contain plus(+) sign.

OK - what you are trying to do is REALLY unusual.

A few things that might help you get around the problems you are having:

  1. Rename your trunk to something simpler. Outbound_0002 (for example) will help. This way, you aren’t trying to use a “+” in the Trunk Name. It probably isn’t a real issue, but it will certainly make this easier to read.

  2. Your route caller ID may or may not allow the “+”. If your provider is telling you to include it, then include it. Otherwise, don’t. Traditionally, your Caller ID field should look like this: “NAME FIELD” <123456789>

  3. You are allowing the extension Caller ID to override the Route Caller ID. I’m not sure this is what you want.

  4. The format for your Trunk Caller ID is suspicious. I don’t think it’s formatted correctly, but check with your upstream provider to make sure.

  5. Are you sure your PJ-SIP settings are correct? I’m not as familiar with the Username field in PJ-SIP, but the SIP Server setting is blank, so if the Username field works with your SIP provider, then cool.

  6. The “from-pstn-e164-us” strips all of the “extra” stuff from the incoming DID. The stuff includes the + sign and other effluvia that Asterisk (and hence FreePBX) don’t need.

I don’t see any one thing that’s wrong with your setup. It sounds like you need to talk to Tech Support at your SIP provider and see what kinds of suggestions they have.

Thanks for your response!!
I think I may not understand about how trunk work and when to use trunk. I need more time to study about it.
If I can ask more clear, I will reply here and ask again what I really want. Or, if I know how to configure what I want, I also will give response here!!
Thanks everybody again!!!

Hi, Dave!!
Another question is I create a trunk and it’s name is ‘Outbound_0002’ (like your example). If I want to register with this trunk, should the username need to be the same as trunk name(Outbound_0002)?

No. The username will be the username your provider sent you. The trunk name is for YOUR use. No one else needs to know your trunk’s local name.