Hosted Freepbx + EndPoint Manager + Grandstream phones setup

hello, i am new to EPM and am trying to learn it to configure phones instead of doing it individually.

the freepbx is hosted version and it has OSS EndPoint manager (it is no longer supported it but works).

the freepbx is completely setup and working with 2 phones but have 18 more phones to add to it. under EPM i have the phones installed, grandstream and the proper model but am confused as to how the phone will communicate with the server, TFTP? where is the TFTP server? the hosted pbx? when i go under Device List, it does not discover the phones when using Search under Global Phone Options, error is “Could not find NMAP, Using ARP only”

would anyone be able to provide a guide from beginning that i can follow and understand the proper setup to get this working?

thank you

anyone here has experience with this??

The phones have to be told which provisioning server to use. This is normally done by setting the boot parameters for the phone via your DHCP server. You could also manually configure the phone to contact the provisioning server. I would recommend not using TFTP for provisioning on a hosted system due to security concerns.

You could not discover the phones because discovery relies on the phones being on the same network as the phone server.

Thank you Alan for the reply.

after hours of looking around, i was able to finally get the phone to communicate with server i think and this is the error i get. i did this by adding the hosted pbx address under “Config Server Path” but i was still not able to provision it. Then i tried adding the folder /tftpboo/ under “Config File Prefix” but still no luck.

here is the error i get after running (the error repeats like 20 times or more)
tail -f /var/log/messages | grep in.tftpd

Dec 19 20:41:55 shotgun in.tftpd[1667]: too many -s directories.

what would you recommend to do for provisioning multiple phones with hosted network? i have few clients and would like to setup a way to provision them remotely either through hostedpbx or make the changes then go to hostedpbx and restart the phone remotely so it can pick up the latest copy of configs. I understand it can be done via HTTP(S) as well but have no idea where to even get started on that. Or can it be done via FTP?

That error message suggests an error with the tftpd server configuration.
What config are you using, possible in the file /etc/xinetd/tftpd file.
Or try ps -ef | grep tftpd that should show you the current running settings eg on my server:-
[[email protected] xinetd.d]# ps -ef | grep tftpd
root 26934 26501 0 23:55 pts/0 00:00:00 grep tftpd
root 27619 1552 0 Dec24 ? 00:00:00 in.tftpd --verbosity 10 -s /tftpboot
[[email protected] xinetd.d]#

You ay its a hosted pbx, in which case I assume its not on your LAN? I don’t think tftp behaves very well through routers particularly if using NAT as well. You might find using http better since it is routable.

looks like it is best to use http or better yet https in order to be more secure and leave tftp alone since it is not very secure and configs can be read easily by anyone picking up a copy of the file. do you have any experience with http setup?