Help with Vodafone Italy Trunk Issue

Hi to all

I’m trying to configure a Vodafone Italy trunk with no lucky.

here my configuration.




My password is correct, copy and paste form my web account
asterisk Configuration is taken from internet
the only information that a get from my ISP provider are:

Username:+3909216???6
Password:???
SIP Outbound Proxy: voip1.fixed.vodavone.it
SIP Domain: ims.vodafone.it
SIP Port: 5060

Here my log:

[2022-11-21 12:26:44] NOTICE[16496] res_pjsip/pjsip_distributor.c: Request 'OPTIONS' from '<sip:+390921****[email protected]>' failed for '83.224.123.48:5060' (callid: 32aac3fc-3997-4c5e-9a7f-be11be258941) - Failed to authenticate
[2022-11-21 12:26:44] WARNING[16496] res_pjsip_outbound_authenticator_digest.c: Host: '83.224.123.48:5060': Authentication credentials not accepted by server.

i hope someone can help me, please!
Thank for your time!

Joe

I always done this way for telefonica, clouditalia, wind, (not tried on Vodafone trunk) :

No server URI
No outbound proxy
No match
Port 5060 specified on client URI and AOR

unfortunately, no luck! Thanks for suggestions!

Please post a link to the working settings.

Sure!
i found actually two. No one work!

1: Configurazione Trunk Pjsip Asterisk su Linea Vodafone - Edmond's Weblog
2: Configurazione Trunk Pjsip Asterisk su Linea Vodafone - Aggregatore GNU/Linux e dintorni

Please try these settings (don’t change anything not mentioned):
Username: +3909216xxx6
Auth username: [email protected]
Client URI: (leave blank)
Server URI: (leave blank)
AOR Contact: (leave blank)

If the trunk is not registered, turn on pjsip logger, paste the Asterisk log for a failed registration attempt at pastebin.freepbx.org and post the link here.

If it is registered but qualify results in errors, paste the log for a failed qualify.

If registration and qualify are ok, paste the log for a failed incoming call, outgoing call, or both.

Hi Stewart1

here: Re: Re: PJSIP Log - FreePBX Pastebin

i leave my number, it’s not a secret actually!

Thanks!

Several things are weird:

Vodafone appears to be “reflecting” OPTIONS requests sent to them, which I’ve never seen before. But then the PBX is trying to authenticate them, which won’t work. Please set Match (Permit) for the trunk to
83.224.123.48,83.224.127.144
(the two addresses for voip1.fixed.vodafone.it) which I hope will eliminate the bogus auth request.

Next, it appears that you have External Address (in Asterisk SIP Settings) set to 151.63.11.202, which my lookup shows as Wind in Milan. But it also appears that your requests are actually coming from 2.38.192.166, which shows as Vodafone in Villa Castelli in the South. Do you have more than one internet connection? If not, please set External Address correctly (after Submit and Apply Config, you must restart Asterisk).

Finally, it appears that your router/firewall is rewriting the source port number on your requests. Avoid that if possible (forwarding UDP port 5060 to the PBX will do that, but you must then be careful with firewall settings). Router/firewall make/model? Any VoIP-specific settings?

If none of these resolve the OPTIONS issue, temporarily turn off qualify by setting Qualify Frequency to 0, so we can see what is happening with registration (paste an attempt if registration still fails).

Hi Stewart1

somethings happens, but not fixed yet. Now making a call from external, asterisk seems to receive it, but fall after few seconds.

  • Added Match (permit)
    -Refreshed the correct external IP! My ISP have dynamic address, maybe its set in the wrong way in the configuration. Can you, please, suggest me the correct way?
    -I have a Technicolor AGHP modem gateway. It seems to block forwarding on 5060 because are used by itself for self phone connectivity (actually disabled).

here the updated log!

https://pastebin.freepbx.org/view/9a8d6aa4

(i have other trunk in this PBX, don’t care, they works great)

Thanks!

Finally…it works!!!

i only delete the trunk, re-create it identical line the link i posted before (the second one):

  • Changed Match (Permit) to 83.224.123.48,83.224.127.144
  • Set my correct public IP
  • Set dynamic IP (i think it’s the correct choose)

Now i can call and receive…BUT
this erros come out when i try to play recordings.
(note that this not happens with other trunks i have, like Eutelia)

365607	[2022-11-23 19:13:02] WARNING[20758] channel.c: Unable to find a codec translation path: (g729) -> (alaw)	
365608	[2022-11-23 19:13:02] WARNING[20758] channel.c: Unable to find a codec translation path: (alaw) -> (g729)	
365609	[2022-11-23 19:13:02] WARNING[20758] channel.c: Unable to find a codec translation path: (g729) -> (alaw)	
365610	[2022-11-23 19:13:02] WARNING[20758] channel.c: Unable to find a codec translation path: (alaw) -> (g729)	
365611	[2022-11-23 19:13:02] VERBOSE[27023][C-00000008] pbx.c: Executing [[email protected]:3] Wait("PJSIP/Vodafone-00000009", "1") in new stack	
365612	[2022-11-23 19:13:02] WARNING[27023][C-00000008] channel.c: Unable to find a codec translation path: (slin) -> (g729)	
365613	[2022-11-23 19:13:02] ERROR[27023][C-00000008] channel.c: Could not set write format to SLINEAR	
365614	[2022-11-23 19:13:03] VERBOSE[27023][C-00000008] pbx.c: Executing [[email protected]:4] NoOp("PJSIP/Vodafone-00000009", "Playing announcement Annuncio benvenuto") in new stack	
365615	[2022-11-23 19:13:03] VERBOSE[27023][C-00000008] pbx.c: Executing [[email protected]:5] Playback("PJSIP/Vodafone-00000009", "custom/Benvenuto,noanswer") in new stack	
365616	[2022-11-23 19:13:03] WARNING[27023][C-00000008] channel.c: Unable to find a codec translation path: (g722|alaw|ulaw|slin) -> (g729)	
365617	[2022-11-23 19:13:03] WARNING[27023][C-00000008] file.c: Unable to open custom/Benvenuto (format (g729)): Function not implemented	
365618	[2022-11-23 19:13:03] WARNING[27023][C-00000008] app_playback.c: Playback failed on PJSIP/Vodafone-00000009 for custom/Benvenuto,noanswer

On the configuration message received from Vodafone they say;
Codec accepted: G.711A-law, G.711 u-law, G.729 (in this order)
In the configuration trunk i set:
Alaw
Ulaw
G729

Wired (for me!!)
thanks!

Although g729 is no longer ‘patent encumbered’ you maybe still need to buy licenses from someone.

No reason (on your system) to mess with g729. Enable only alaw and ulaw for the trunk, and confirm that the announcement exists in alaw and/or slin.

If you still have trouble, paste a log including pjsip logger.

That was easy. Simply disable g729 and all the recording works fine!

Thanks for all, for real!

Thanks a lot!!

Joe

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.