Help with G711 Codec payload size and bandwidth usage

Our NE used wireshark to capture some calls, said “Currently it appears voip calls consume a little more than twice the amount of bandwidth they should, possibly due to payload size (ms or bytes) being set to the minimum setting.”

They want me to show them the settings from our PBX for payload size. (Default is 20ms, options are 10, 20 and 30 ms)

I couldn’t find this info looking at the settings in FreePBX Admin, or searching online, or in the asterisk guide, I do know we use G.711 codec but not sure where to configure the payload size. Is there a .conf file I just need to look in to be able to provide this?

Besides that, any tips on general things to look into to reduce bandwidth utilization (besides changing over to G729)?

Thanks in advance,


PBX Firmware: 2.210.62-1
PBX Service Pack:

Wireshark numbers:

KB	seconds	KB/s	total kbits	kbps	total packets	PPS		

call 1 69 3 23 552 184 276 92 171200
call 2 52 2 26 416 208 202 101
call 3 455 19 24 3640 191.5789474 1877 98.78947368
call 4 968 40 24 7744 193.6 3994 99.85
call 5 234 10 24 1880 188 966 96.6
call 6 432 18 24 3456 192 1780 98.88888889
call 7 220 9 25 1760 195.5555556 907 100.7777778

packet size 1712 bits

You will always trade-off quality against bandwidth for any particular codec.


He did the bandwidth calculator, and calculated off of 10ms, but said it still looked like we were using higher than normal. Attached screenshot of the calculator.

Do you know where exactly I would go to see what payload is set to?

from that RTP packetization wiki: " append that interval to the allow= statement."

Not sure what conf file this would be located in so I can go in and see what it’s set to… Looked in sip.conf and sip_additional.conf , not seeing any lines like that in there. Lost.

Appreciate your time,


The default “VPI” is 20ms , I don’t think you change thatr in the GUI the “allow” is in effect a checkbox.

I don’t agree with his calculations, as a rule of thumb you should generously allow 80kbs each way for each call or any QOS might not work well , the 80-64 is for the headers you can reduce it a little sometimes by adding trunk=yes to your connection if your provider supports sip trunking and you have multiple concurrent calls.