Help moving FreePBX to new hardware - dahdi module not working

The dahdi config web page stops working when the dahdi card is not found.

Testing a failover scenario, i.e. moving FreePBX to a new system but with different hardware.

Restored backup on new hardware, and after reconfiguring the network cards can connect to the GUI

The original system has 1 pri card. Not surprisingly this is not found on the new system. The pri card (sangoma a101de) is at a different pci bus address on the destination system.

So I followed what was needed to originally install the card, i.e. disable the dahdi module, run wancfg manually, then re-enabled the dahdi module.

But still the dahdi config GUI page is still stuck. Only the restart button works.

Any ideas? Is it possible to wipe the dahdi config from the system? And start new but without removing the complete config.

lspci shows the card

08:04.0 Network controller: Sangoma Technologies Corp. A200/Remora FXO/FXS Analog AFT card


pci:0000:08:04.0 wanpipe- 1923:0040 Sangoma Technologies Corp. A200/Remora FXO/FXS Analog AFT card

And wancfg finds it…

Would you like to generate /etc/asterisk/chan_dahdi.conf

  1. YES
  2. NO

Configuring T1/E1 cards [A101/A102/A104/A108/A116/T116]

A101 detected on slot:4 bus:8

Software Installed:

fwconsole --version
FW Console - FreePBX Utility version

asterisk -V
Asterisk 11.25.1


First - the program ‘dahdi’ has to be running correctly before Asterisk starts. Make sure that you’ve restarted it after the config files get created. You may want to try running from the command line just to make sure everything is working.

Check your log output. If there are problems, they should show up there.

There are other dahdi_(etc) programs in /usr/spool/bin that you should be using to check your hardware.

Once you’re sure that dahdi is running and that the system has configured the card correctly, start Asterisk up and “grep dahdi /var/log/asterisk/full” to see what kinds of problems Asterisk is finding in your DAHDI setup.

Remember that FreePBX’s support for DAHDI is as a configuration web page. It really isn’t very good at “controlling” DAHDI, since dahdi starts way before anything like FreePBX starts.

Double check the files that are being used to configure the port. Every component in the string has to look in the same place or you’ll end up with conflicts that can be really hard to find.

Finally, make sure that your module is configured to make changes to the files.

thanks Dave. Quick response!

Yep I gave up on FreePBX gui and dahdi when I first installed the setup (Sangoma FreePBX 300) and it did not see the pri card (a101de). Thanks to a forum post on here pointing me in the right direction. I believe the dev effort is going into the next release and the problems lie in non freepbx code anyway.

Finally tracked down the problem - little embarrassing but it is late here :slight_smile:

With the wancfg_dahdi script, was actually exiting before applying the config…

# /usr/sbin/wancfg_dahdi
Configuration Complete! Please select following:
 1. YES - Continue
 2. NO - Exit

So choose “1” and all is well.

The pri span is also the same name as before so the config looks well. Now for some late night testing.

So to recap:
After restoring filesystems on new hardware and getting that all to boot, removing raid config, recreating networking devices, rebuild initramfs, etc,
In freepbx disable dahdiconfig module, reboot
Run /usr/sbin/wancfg_dahdi, reboot
In freepbx re-enable dahdiconfig module, reboot

Thanks again - Allan