Help me fix enabling webrtc on FPBX 14


(Jly26) #1

I want to use webrtc on my freepbx 14 hosted on my vps.and I can access my FPBX GUI FQDN on https:// sip.my domain .com and UCP via https:// sip.my domain. com/ucp/ without any issue using LE cert…so I install webrtc and enable phone on UCP on my test pjsip ext, import my LE cert using certmanager…I check http show status to confirm websocket listening address and port… then run nmap on my router to confirm open port on my FPBX VPS…

Running: /usr/local/bin/nmap  -sS 'sip.xxxx.xxx'
Starting Nmap 7.80 ( https://nmap.org ) at 2020-05-09 11:07 +03
Nmap scan report for sip.XXXXXXX.xyz (xxx.xx.xx.4)
Host is up (0.12s latency).
rDNS record for xxx.xx.xx.x: vpn.myhauz
Not shown: 995 filtered ports
PORT     STATE SERVICE
22/tcp   open  ssh
80/tcp   open  http
443/tcp  open  https
8088/tcp open  http-proxy
8089/tcp open  radan-http

Nmap done: 1 IP address (1 host up) scanned in 8.23 seconds[spoiler]This text will be blurred[/spoiler]

Then I log in on my UCP and I received phone disconnected status

so I change asterisk https port to 8080 but same issue…please see attach console debug issue…Hope someone could help me fix this issue…


(Jly26) #2

anyone??
update: I connect to FPBX through vpn…then I type this on my chrome browser htttps://10.80.0.1:8089/ws to check if I can connect to it and I got this,

Upgrade Required
Asterisk/13.33.0          

then I disconnect my vpn client and I type using fqdn https://sip.mydomain.com:8089/ws on my browser , still connection refused .even disabling my firewall and apache2 server …

HTTP Server Status:

Prefix:
Server: Asterisk/13.33.0
Server Enabled and Bound to [::]:8088

HTTPS Server Enabled and Bound to 0.0.0.0:8089

Enabled URI’s:
/httpstatus => Asterisk HTTP General Status
/ws => Asterisk HTTP WebSocket

Enabled Redirects:

root@bh00795:~# lsof -i :8089
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
asterisk 17455 asterisk 38u IPv4 3493155 0t0 TCP *:8089 (LISTEN)
root@bh00795:~# lsof -i :8088
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
asterisk 17455 asterisk 12u IPv6 2898389 0t0 TCP *:omniorb (LISTEN)


#3

Not sure where you are going with those steps but start by changing things back to how they were :slight_smile:

Great documentation in the wiki: https://wiki.freepbx.org/display/FPG/UCP+Phone

https://wiki.freepbx.org/display/FPG/WebRTC+Phone-UCP

One last point is to make sure you have enabled the WSS transport in PJSIP settings:


(Jly26) #4

thanks,sorry for confusion what I mean is I did try to change the default port from 8089 to 8080 just to check it I can connect to that new bind port but the same problem…I did enable wss in chanpjsip settings and my certificates imported via certmanager…i copy my LE apache2 cert to /etc/asterisk/keys and did fwconsole cerficates import and set default…I turn off my firewall too but same connection refused…


#5

In the Asterisk advanced settings, be sure the mini HTTPS server section also correctly points to your cert/key. The “integration” cert and key should be copies of your default; certificate manager puts them there for this purpose.


(Jly26) #6

@billsimon

Thanks man…problem was my certificate…


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.