Help Accessing Sangoma FreePBX 100 With Putty

Hey everyone,

I’m trying to access my Sangoma server to reset the root password for our phone server installation. I’ve used this guide to access the server via a serial cable using putty.

I’m using the COM port found in device manager, the speed listed in the aforementioned guide, and the driver from Sangoma, but putty is an empty window and I can’t see or type anything. I’ve tried on a windows 10 and Windows Vista machine.

Anyone have any ideas on how I can get this server talking to putty?

Thanks in advance!

I believe that Sangoma servers have the same console pinout as Cisco routers; for example see .

With the cable connected to your PC but disconnected from the server, start putty. Characters typed on the keyboard should not echo to the screen. Then, connect a jumper between pins 3 and 6 of the RJ45 (these would be the green/white and green wires on a normal Ethernet jack, corresponding to TXD and RXD on the console cable). Characters typed should now be echoed to the screen. If not, there is something wrong with your putty setup or console cable.

Once that’s working, connect the console cable to the Sangoma server. When you power on the server, you should see boot up messages on the screen. If you see garbage characters, check that speed, etc. is correct. If you see nothing, check that power, etc. are ok. If the server is otherwise alive the VGA port should be active.

1 Like

Thanks so much for your response. I’ve never done something like this before. What’s the best way to jump those 2 pins? I’ve never tried jumping an rj45.

And just to clarify, the jumping process is just to ensure that the cord/putty are working correctly?

I replaced the console cable with the one you linked and Putty now echoes on screen. Thanks for your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.