Having trouble with a Trunk and Outbound route


(George F) #1

I have a trunk for a GrandStream GXW4108 PSTN Gateway. During the setup I followed the guide in the wiki freepbx display FOP Configuring+a+Grandstream+GXW-410X+Device+to+act+as+an+FXO+Gateway.
I set this up with 5 lines on the first 5 channels, and all lines coming into 1 IVR, and all lines in 1 trunk that is connected to 1 outbound rule.
This worked great for the setup for everything but outgoing calls. I can only make 1 outbound call, every time I try to make another call, I get the “All Circuits are busy, please try again later” message with the other 4 lines not in use at all. I did notice that the call is being made through the 1st line, even though I have it set up for Round Robin on all of the lines and GrandStream says it will use the highest available line and work its way to the lowes. IE: 5, 4, 3, 2, 1 in my case.


#2

I know zero about the GXW4108 but I did use a Cisco SPA8800 which had multiple FXO gateway ports. I had to create one trunk for each port and set one channel for each trunk. Then on my outbound I added the multiple trunks as possible routes. Not sure if this helps…just tossing this out.

Thanks,

Gordon


(George F) #3

I have tried this, and it did not work… I will try it again… I think that is a strange way to resolve the issue… I do use an old AudioCodes FXO with 8 ptsn lines and round robin setting without an issue. Not sure why the grandsream will not work that way.


(George F) #4

I try this, even using the ports that grandstream says it uses for each line, the grandstream still uses line one when I call out on a line with the port for line 5… so I need to find the setting in the grandstream to make the Round Robin calling work… I have the outbound dial plan set for Round Robin 1 to 8… when I resolve this, I will post what made it work. This FXO is great at having very clear and good lines… just a pain to get outbound calls to work correctly.


#5

Did a little searching and saw this

Looks like a multi trunk was used with another Grandstream. For my troubleshooting I setup a multi trunk but enable only one trunk and walked through each port to ensure each is working.

Example:
Line 1 - on
Line 2 - off
Line 3 - off

Then
Line 1 - off
Line 2 - on
Line 3 - off

Best of luck, when you figure this out it would be helpful if you post back a detailed solution/fix. Better yet nice How To Guide. : )

Thanks,

Gordon


(George F) #6

Yea, this is for setting each channel up with SIP registration… My need it to get the GrandStream to work with Round Robin settings. Ever line works… just Round Robin doesn’t. Can only make 1 call out!


(George F) #7

Wow, I have it all working… Appears that my only problem is with setting up the number for outbound calls… So all I needed to do is set up an outbound route with all the digits for outbound calls – in my case this was nxxxxxx and nxxnxxxxxx… Make sure you have no 7 or 10 digit extensions (not sure why anyone would)… and then use the 7 digit pattern for local numbers and 10 digit for others… we have a different route for international calling. Then in the GXW410X PSTN Gateway on FXO Lines dialing out use this Outgoing Call Dial Plan {<=1630>xxxxxxx | <=1>xxxxxxxxxx} Replacing 630 with your local area code. And it should work… That being said you have the have the other setup working… If you need help with that I can share my experience… just ask!