Grandstream HT813 doesn't hang up FXO :(


(Jhauxwell) #1

Hello,

I have spent hours on this problem with no positive result so I’m hoping that somebody on this forum might be able to help.

I have a Grandstream HT813 connected to my Freepbx with the FXO port configured and receiving calls works (including caller ID which i see as a bit of a bonus!)

The problem is that if i call my freepbx from an external phone (i.e. my mobile phone) when I disconnect the call on the external phone, freepbx doesn’t hang up…or perhaps more accurately, the HT813 doesn’t hang up.

Now I can see on the configuration page for the FXO port on the HT813 that there are options for FXO Termination and here are my settings:

To diagnose the issue further I turned on call recording on freepbx and recorded what happens from an audio point of view on the call when it is disconnected by the far end and my analogue telephone line provider does indeed send a tone which is recorded during the call recording - here it is on the audio file:

(It would appear that new users can only post one image so i may have to reply to my own thread to post the other images)

Now, using the Frequency Analysis tool in the audio editor I can confirm that the tone is 400 Hz

Which agrees with all of the information i can find online about what it typically is.

The problem is, the HT813 does not drop the call even though I know without any doubt that the tone is there, because freepbx records it.

I am at a total loss. Does anyone have this working?

Thanks in advance.

Joel.


(Jhauxwell) #2

Here is the Frequency Analysis of the tone on the recording


(Jhauxwell) #3

This is what the recording file looks like

the called extension on freepbx just stays connected until the timeout threshold is reached.


#4

Unfortunately, the Grandstream documentation is not good. A credible post at


suggests
f1=400@-30,f2=400@-30,c=0/0;

I’d try that first. If it works but you get some false disconnects, try
f1=400@-24,f2=400@-24,c=0/0;
If it doesn’t disconnect at all, perhaps try
f1=400@-30,f2=400@-30,c=3000/0;

If still no luck, perhaps syslog from the Grandstream will show partial detection of disconnect and give a clue as to how to fix.


(Jhauxwell) #5

Hi Stewart,

Thankyou so so much, your first suggestion worked.
I spent hours trying different things yesterday and so this is a real result.

All best,
Joel.


(system) closed #6

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.