FreePBX trunks with Thinq - Anyone have experience?

Hey guys,

Just trying out Thinq as a provider for the first time… Does anyone out here have Trunk configuration settings that work with them ?

I’ve tried various settings on my own but can’t seem to get it to work… Outbound and Inbound… not working at all… Thinq seems to work only with IP… no registrations… i’ve never done it that way before…

Tried this –

; allow=g729 ; uncomment if you purchased g.729 from Digium

but not working at all…

Any help greatly appreciated.


Use pjsip.

Tried PJSIP – not much luck there either…

Authentication to None, Registration to None

Sip server port 5060

Context – tried from-pstn and from-trunk

Transport left it as it was

Do they even offer SIP trunking? It is not mentioned on their website.

Yes they offer SIP trunking… I was able to get the inbound working… I have a Trunk connected now… I had to lock down the firewall by IP and allow anonymous connections… Thinq is locked down by IP on their end also…

My Incoming settings are:

Calls are coming in just fine… but can’t seem to dial out…

I am getting this error –
Got SIP response 484 “Address Incomplete”

in the outgoing settings i have:


Still trying to figure out the outbound…

Do you gave a “technology” prefix set on your ThinQ trunk?

You should stop trying to guess and ask your provider to give you the exact parameters needed to configure the trunk.

By the way, insecure=very has been deprecated a long long time ago. You should be using insecure=port,invite

Unfortunately the provider has no parameters to offer me really… I already asked for assistance there.

I do not see a “technology” prefix anywhere in the trunk setup… only my originating IP and that my traffic has to be directed to

That’s incoming, not outgoing. Two very different things.

Also, it looks like you are using Chan-SIP. I recommend this now, especially when the call could be coming from more than two or three IP addresses. You should transition to PJ-SIP and identify all of your incoming addresses that way.

If you are going to continue with Chan-SIP:

Should probably be “type=friend” to allow the settings to carry over to the Outbound settings.

That setting has been deprecated for about 10 years. As noted above, you should be using “port,invite”.

For testing purposes, stick with ulaw for now. It’s universally supported (in the US) and gets rid of one more variable.

Make sure all of your settings in the Advanced Settings tab for your SIP production are set up for this. You need to double-check the inbound router as well to ensure traffic is being forwarded correctly if you are, in fact, using NAT.

insecure=port,invite is often copied from cookbook examples even though insecure=port is not required in most of the cases it is used, and insecure=invite has also been replaced with a more modern version and that is remotesecret.
So if you use remotesecret instead of secret you achieve what the user probably wants and that is to not challenge incoming invites for authentication but provide the secret if challenged on outgoing invites.


Ok guys… finally got it all working… so for anyone looking to use Thinq… here’s what you need to do…

For inbound:

In Settings > Asterisk SIP Settings > Security Settings

  • Allow Anonymous Inbound SIP Calls
  • Allow SIP Guests

Now obviously you’ll want to lock down your box so that only the Thinq IPs can get in…

For outbound:

When setting up the Trunk… Use Custom Trunk
and in the Custom Settings tab use this custom dial string – SIP/[email protected]

That’s what did it for me… working fine now… in and out


This is not really the best answer for this at all.



reads rest of post

Hmmm. While I’m sure you have calls working, you have not done it in a way that is securable. I would not recommend anyone follow this recipe.

Unless there’s another way to accept calls from a specific incoming IP without registrations… Thinq’s system works with destination IP and nothing else… I was not able to get the incoming to work any other way…

Any other suggestions welcome of course!

Pretty much every single trunk works this way, even the ones using registration. Inbound INVITE comes from recognizable IP, route call to specified context. You either create one chan_sip peer per signalling host, or a single pjsip trunk with all signalling hosts enumerated on the match line. Then white list the signalling hosts/ranges in firewall.

Just like this.

Various advanced settings can be changed depending on the specific needs of the SIP provider.

Opting not to read scroll back, so apologies if it’s been discussed. I’ve encountered a surprising number of people using non-registration trunks that don’t realize they must correctly match the signalling port on the provider end with the trunk port on the PBX. So if you create a PJSIP trunk, and the PJSIP signalling port is not 5060, you must specify that at the provider end.

1 Like

Ok I am trying the PJSIP setup… however I get the “all circuits are busy” message when dialing out… how can I make sure PJSIP sends out in the format Thinq needs – ie: SIP/[email protected]

At the Asterisk command prompt, type
pjsip set logger on
and make a test call. The SIP trace will appear in the Asterisk log.