freePBX suddenly freezes up on AWS

I’ve been running freePBX as an Amazon Linux 2 instance for many months now without issues but lately after a few minutes, it disconnects any registered extensions.

At first I thought I was running out of memory, so I changed the instance type to increase the memory. That did not solve the problem I also don’t have any problems with space.

When it freezes up like this, I sometimes are unable to login to the Linux instance but sometimes I cannot bring up the GUI but sometimes I can.

The AWS log for the instance doesn’t show anything and I don’t know where else to look to troubleshoot this.

After stopping and starting the instance again, I am able to register but it drops again after a few minutes

If I am able to access the web GUI, it is very slow and the dashboard does not load nor do many of the other links from the menu

I’ve increased memory by changing the AWS instance type to t2.small, which gives 2gb. Initially, thật seems to have improved things but I haven’t tested it completely yet.


I thought with 2gb of RAM that it would solve the problem. No luck. I tried to add another extension but on submit, it said RELOADING for over 10 minutes. It never completed.

Something is fundamentally wrong so I’m going to zap this instance and start over

probably a network thing, some useful tools here

remember that not all protocols are equal and some hosting companies mess with some ports

AWS doesn’t. My firewall has all necessary ports open.

then its something else, but still i would check the network

Network connectivity and latency check out okay

by what measure do you say that?

A wireshark capture of a gui session and an rtp dump of an active call would be a good start

I just used traceroute and ping from two different locations. I do not have my laptop with me at the moment. Will try Wireshark later.

both of those use icmp, I would look at a more rigorous testing with iperf (qperf) to better look at udp/tcp bottlenecks, iftop for a quick looksee for when the Amazon machine is unresponsive, do that from two networks if feasible to eliminate a ‘local’ prob

Iperf is not installed. There may be some learning time here

Unfortunately, after I login, ít is is so sluggish that I can’t install it

I may migrate to another region

Got it installed and my client connects.

i had same issue after installing asterisk 16.24.1 and FreePBX 15.0.23. The extension could not register, i tried to go to Asterisk Info and the page was loading no respond but the other pages was ok and after i did fwconsole restart everything came up so not sure what was wrong. my server is not on AWS , will see if it happens again and let you know

No joy with that either. fwconsole restart stalls for a minute or so then displays a bunch of php messages. The GUI only loads to 90% and is pretty much unresponsive.

By what method are you installing FreePBX?

After I migrate to another region I’ll check out the network but I don’t think it’s a network problem.

That wasn’t an answer to my question.

It’s been awhile. What methods are there? Maybe I’ll remember

We can’t share your memory :-), but generally you would take a known working method for your chosen platform.

Yes. I may have used an AMI. Whatever it was, I can install commercial modules

Apparently “Some one left the cake out in the rain”