FreePBX Registration Issue

So our FreePBX v14 (asterisk v13) server died last week (only 10 months old HDD failure) and I had to rebuild it over the weekend. The backup was on the server and I had not gotten around to copying said backup to external flash drive or other location. So, unable to restore my backup. None-the-less, I have rebuilt the server with RAID and reinstalled/configured just about everything, except I am having a weird registration issue. My provider says the registrations are successful, however at the CLI, when I type ‘sip show registry’ it returns ‘0 registrations’. Users have informed me that incoming calls work, paging system works, however, outgoing calls do not-

freepbx*CLI> sip show registry
Host dnsmgr Username Refresh State Reg.Time
0 SIP registrations.

I also enabled pjsip set logger on-

<— Transmitting SIP request (468 bytes) to UDP: —>
Via: SIP/2.0/UDP;rport;branch=z9hG4bKPj725fd3dd-7cfd-40af-9d19-ffa0dda5c782
From: sip:[email protected];tag=365b0431-723e-48e6-83df-a5aaa01ecefc
To: <sip:<USER_NAME>@>
Contact: sip:[email protected]:5060
Call-ID: 8f82e98a-f530-4a1f-8aec-f5aa9d05235e
CSeq: 5722 OPTIONS
Max-Forwards: 70
User-Agent: FPBX-
Content-Length: 0

<— Received SIP response (392 bytes) from UDP: —>
SIP/2.0 200 OK
Via: SIP/2.0/UDP;rport=5060;branch=z9hG4bKPj725fd3dd-7cfd-40af-9d19-ffa0dda5c782;received=
From: sip:[email protected];tag=365b0431-723e-48e6-83df-a5aaa01ecefc
To: <sip:<USER_NAME>@>;tag=40a1fb4598fa77a347606dda867c43cf.caba
Call-ID: 8f82e98a-f530-4a1f-8aec-f5aa9d05235e
CSeq: 5722 OPTIONS
Content-Length: 0

Looks good but the PBX will not and does not show it is registered. Provider verified it is good registration. Does not see outbound calls from us.

Any ideas as to what is going on? Or how to correct our PBX?

Additionally, they said I should not use IP address and should use DNS SRV as they have a pool of 6 servers and I would have redundancy… agreed!

Any guidance on setting my trunks up for this?

Thank you,

You should probably switch to the newer PJSIP stack. The old chan_sip module doesn’t handle DNS SRV/NAPTR records correctly. Maybe your problem goes away when you do that.

He is using PJSIP according to the name he used.


pjsip show aors

I bet it is there, if so this will be useful:

core show help pjsip

Then setup your outbound route. If it is, get us a debug.

freepbx*CLI> pjsip show aors

  Aor:  <Aor..............................................>  <MaxContact>
Contact:  <Aor/ContactUri............................> <Hash....> <Status> <RTT(ms)..>


  Aor:  300                                                  1
Contact:  300/sip:[email protected]:5060                 2463dea3ad Avail         6.518

  Aor:  301                                                  1
Contact:  301/sip:[email protected]:5060                 f432cddcba Avail        11.286

  Aor:  302                                                  1
Contact:  302/sip:[email protected]:5060                 8df7c47554 Avail        10.751

  Aor:  303                                                  1
Contact:  303/sip:[email protected]:5060                 ac1e4ae264 Avail        11.579

  Aor:  304                                                  1
Contact:  304/sip:[email protected]:5060                 0915e9b716 Avail         5.655

  Aor:  305                                                  1
Contact:  305/sip:[email protected]:5060                 1254da2843 Avail         7.207

  Aor:  306                                                  1
Contact:  306/sip:[email protected]:5060                 01cf432209 Avail        16.015

  Aor:  307                                                  1
Contact:  307/sip:[email protected]:2049;line=ff4k6gbl   84c5893719 Avail        24.016

  Aor:  308                                                  1
Contact:  308/sip:[email protected]:2048;line=i1dj6xd2   89bf80e4a6 Avail        24.233

  Aor:  309                                                  1
Contact:  309/sip:[email protected]:5060                 b1caee0fd6 Avail         8.157

  Aor:  310                                                  1
Contact:  310/sip:[email protected]:5060                  776738ec9c Avail         8.867

  Aor:  311                                                  1
Contact:  311/sip:[email protected]:5060                 90c502f83d Avail         5.807

  Aor:  312                                                  1
Contact:  312/sip:[email protected]:5060                 34decbe615 Avail        12.633

  Aor:  NexVortex-PJSIP1                                     0
Contact:  NexVortex-PJSIP1/sip:[email protected] 55f24120cf Avail        81.969

  Aor:  NexVortex-PJSIP2                                     0
Contact:  NexVortex-PJSIP2/sip:[email protected] e24b8f03a9 Avail        44.610

Ok Thanks!

My extensions and trunks are PJSIP

In FreePBX under Reports Asterisk Info it shows the Trunks are registered. When I access the Asterisk CLI and type ‘sip show registry’ it returns ‘0 registrations’
I restarted the asterisk core and still nothing.

extensions 307 and 308 are snom PA1 pagers - FYI

Because that’s only for chan_sip. The equivalent for pjsip is
pjsip show registrations

Though I know nothing about NexVortex, very few providers require registration to make outbound calls, so it’s unlikely that even if you are failing to register it’s related to your issue.

At the Asterisk command prompt, type
pjsip set logger on
make a failing attempt at an outgoing call, paste the Asterisk log (not the console output) for the call at and post the link here.

freepbx*CLI> pjsip show registrations

<Registration/ServerURI…> <Auth…> <Status…>

NexVortex-PJSIP1/sip: NexVortex-PJSIP1 Registered
NexVortex-PJSIP2/sip: NexVortex-PJSIP2 Registered

Objects found: 2

solved part of my question, thank you.

We made several call attempts today and NexVortex did not see any of them hit their system. Never got outside the PBX. Yes there is an Outbound Route(s) - fully configured.
One for emergency, one blocked for long distance prefixes off shore and the final is our Outbound route for all other calls.

I just tried ‘grep 9252605790 full’ on the Asterisk Logfiles and nothing.

Possibly the phones got incorrectly provisioned, or are not reaching Asterisk for some other reason. What does the caller hear? What displays on the device? Does anything get added to /var/log/asterisk/full when you attempt a call?

So he used the wrong command, I saw only sip show registry. How do you see from the OPTIONS dialog that it is PJSIP?

hey guys,
Everything is PJSIP (Extensions and Trunks) Trunks are registered.
I re-provisioned all the phones this morning. Save-rebuild configs-update phones.
Endpoints still unable to make outgoing calls.
When they dial my number they hear the DTMF echo and then the extension just sits there. It shows, my name and my phone number. On the display too the left of the number they dialed there is an icon of a phone with a red x or slash through it. After 10 seconds it drops the call attempt. I’ll see if I can get anything from the log and post it. But prior attempts to grep the log came up empty. The AOR shows all the extensions so I know they are connected.

You asked for a debug of the outbound routes - how do I do that? Sorry I am not very experienced.
Thank you,

Trunks registered but still no calls.
I erased and re-configured 1 extension to test and still nothing.
Disabled firewall and tried still nothing.
Logs empty
Please help.

Now as soon as they dial my number as a test call it drops immediately no 10+ second delay before it drops…

Hey Stewart,
I tried the following-
disabled Sangoma Firewall. Checked intrusion detection - nothing noted.
Nothing is added to the logs.
I checked and updated my Extensions, Extensions Mapping and Global Endpoint Settings.
I am at a loss. Now there is no delay when user dials a number, it drops almost immediately with out any delay. Nothing is noted in the logs when user calls.
using the following: grep full
Any ideas or things to check?
AOR’s look good.
Thank you,

Hi Stewart,

here is the verbose call log for a dropped call (at the bottom) they just tried calling my cell phone. Call dropped immediately. Something about it being restricted. Not sure why. Please let me know what you think.
Thank you,

Indeed, the log shows that extension 306 is restricted from calling the 1925 number. I assume that you are using Extension Routing and not using Class of Service. If that’s not the case, provide details.

On the Additional Settings tab for the Outbound Route in question, confirm that 306 is in the list of Allowed extensions. After Submit and Apply Config, restart Asterisk. If you still have trouble, post screenshots of your Outbound Routes, including the Dial Patterns and Additional Settings tabs.

Hi Stewart,
Thank you. I just deleted the outbound routes and re-created them. I corrected a couple issues now they calls are not dropped but they get Asterisk Allison saying the call could not be completed as dialed, so some progress. Here is a new pastebin.
Yes all my extensions are in the allowed list. i’ll see about some screen shots of the config.

Thank you for your help.