FreePBX Not Detecting Sequential DTMF Tones

configuration
freepbx
Tags: #<Tag:0x00007f70217dac38> #<Tag:0x00007f70217daaf8>

#1

I have a strange issue going on that I can’t figure out. I have an IVR setup for inbound calls, and when the caller enters a single digit, FreePBX detects it correctly. If I enter a sequence of digits, such as 1234, it says invalid option. I tried recording the incoming call, and I don’t see or hear any duplicate tones (both pre and post echo canceler). This makes me think it is an issue somewhere in the configuration.

The issue is not limited to inbound calls, as I also have a landline phone hooked up to one of my FXS ports. On the FXS extension I can dial out phone numbers directly, but if I enable “Route Password” It will keep saying incorrect password. I’m guessing this is again caused by it not recognizing the correct tones. I still don’t understand why it works fine without a route password, but won’t work with one.

I’m currently running FreePBX 10 and Asterisk 13, since that is the last version to support 32-bit devices. Is there a location where DTMF tones are logged, so I can actually see what it is picking up? Any advice would be appreciated.


(Dave Burgess) #2

Logs with DTMF debugging turned on would probably help a lot.


#3

I think I found the issue for the incoming calls. I had the timeout set lower than the digit timeout, and watching the logs it detects the correct IVR path now.

I’m still not entirely sure about the FXS extension. I have had multiple problems trying to get it to work correctly. For some reason the phone won’t ring, but If I pickup the receiver when calling from my cell phone it will pickup the call. I’m wondering if it’s not getting enough power.


#4

Depends on your FXS hardware, DAHDI or ATA, if DAHDi, do you have your molex plugged in?

(you are fighting a losing battle with a 32 bit system)


#5

It’s DAHDi, but there is no molex plug. Here is the card I have: https://www.amazon.com/Ports-Supports-Asterisk-Freepbx-Issabel/dp/B07DKZCTM4/ref=sr_1_3?dchild=1&keywords=fxo+card&qid=1605393665&sr=8-3

I’m guessing it’s one of the knockoff cards, but so far it has been working fine, apart from this issue with the FXS port. I’m thinking it will be better in the long run just to buy a VoIP phone.


#6

Are you sure? no white plastic 4 pin male connector ? The PCI bus can’t supply enough battery to ‘ring’ an FXS device so normally needs the yellow 12V power.


#7

Yep, looks like the knockoff cards don’t have one. From looking up pictures of the real card, it has a molex plug on the end. It looks like I will need to go in the VoIP direction then. Everything with the FXO port is working now, just not enough power for FXS extensions.