FreePBX - No Audio until Hold Music

Hi All,

Hoping someone can help me with this one…

I cannot get the outbound or inbound audio to work until I put the hold music.

Here’s my current setup details:

Raspberry Pi, FreePBX
Sophos UTM with SIP Helper and NAT UDP 5060 > FreePBX Box.
1 x iPhone 7, Zoiper Free, logged in as Test
1 x Samsung Galaxy S9, Zoiper Free, logged in as User1

Dial (Using 4G Cell network) Test > User1 =GOOD
Dial (Using 4G cell network) Test > Landline = No two way audio (cannot hear either party) until HOLD button pressed on Zoiper, then audio works.

Dial (Using internal wifi network with Freepbx on Subnet) Test > User1 = GOOD
Dial (Using internal wifi network with Freepbx on Subnet) Test > Landline = GOOD

Anything I should be trying next? Why would putting the call on hold allow the voice to work?


Try turning this off.
Also try forwarding ports 10000-20000 to your PBX.

My experience with this specific problem was a codec problem. The hold music was “wav” and everything else was GSM. For some reason, once the ‘wav’ files started, the system was able to switch back to the GSM codec and successfully worked after that. Of course, it could have also been a coincidence, since we know that not having the RTP ports set up to point at the server from the firewall will cause this as well.

The theory on that is that the hold music starts a new session with the router (from the server this time), which can then return the audio to the server (since the NAT path through the router is working correctly.).

Thanks! - I noticed a lot of RTP packets dropping, after a quick adjustment… a noticeable difference no more drops.

However, now hitting an issue of:

Dial (Using 4G Cell network) Test > User1 = Outbound Audio GOOD, inbound Audio NOT WORKING… even with the hold on/off trick.


Under SIP Settings, can you check if everything is right?

“Asterisk is currently using chan_sip for SIP Traffic.” Everything looks standard, no big changes other than the external IP and local networks listed all look good.


So seems I have tracked it down to a single scenario.

If the device is on the GSM/3G/LTE network and makes a call from the Zoiper App, the receiver can hear, but the Zoiper app cannot.

So the person on the other end can hear audio fine, but audio coming BACK into the FreePBX is missing.

On wifi everything works both ways, its just one way audio using cellular data.

Seems this issue is on Zopiper’s end. Have you tried using a PC solution such as x-lite, or just having the call forwarded to your cell phone number? Otherwise you could try using a different softphone app on your phone.

A SIP trace will tell you where the loss is occurring. We’ve seen scenarios with Zoiper like this in the past. Make sure the NAT settings are correct everywhere. Zoiper, the extension, everywhere.

Just done a forward directly to a cell number.

Landline Dial SIP mainline, hit IVR, Option 8, FreePBX forwards call to Cell phone.

Audio 2 way no problem.

You could also use google voice and set that up with Freepbx. As long as you setup the Outbound routes and Inbound routes that should work on your phone using zoiper. This also makes it much cheaper than paying for service, unless of course google voice is unavailable to you.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.