FreePBX GUI is unreachable

I can no longer access the FreePBX GUI, and can no longer SSH into FreePBX using Putty. I keep getting “This site can’t be reached took too long to respond” in my browser when attempting to open the FreePBX GUI. I also get the error message “Network error: No route to host” when attempting to SSH using Putty. Windows 10 host, FreePBX Hyper-V guest virtual machine. When I start the VM, FreePBX automatically logs into the CLI and displays the ip address i can access the gui with

These problems began immediately after I added to the trusted zone using the GUI. After saving these settings and refreshing the browser, i could not open the FreePBX GUI after that.

Here is what I’ve done/checked so far:

  • Confirmed that the Asterisk service is running, it is (service asterisk status, service asterisk start)
  • Restarted FreePBX twice within 5 minutes (shutdown -r now). After the message “Firewall is currently in delayed startup mode,…” appeared, i refreshed the browser but still could not access the GUI.
  • Listed the trusted zones (fwconsole firewall list trusted). “All entries in zone ‘trusted’:”
  • Deleted (fwconsole firewall del trusted
  • Restarted FreePBX (fwconsole restart)
  • “fail2ban-client status” results in:

Number of Jail 7
Jail List apache-tcpwrapper, recidive, ssh-iptables , apache-badbots, pbx-gui , asterisk-iptables, vsftpd-iptables

  • Checked jail.local (vim /etc/fail2ban/jail.local):

ignoreip =
bantime = 1800
findtime = 600
maxretry = 8
backend = auto

enabled = true
filter = asterisk-security
action = iptables-allports[name=SIP, protocol=all]
logpath = /var/log/asterisk/fail2ban

enabled = true
filter = freepbx
action = iptables-allports[name=SIP, protocol=all]
logpath = /var/log/asterisk/freepbx_security.log

enables = true
filter = sshd
action = iptables-multiport[name=SSH, protocol=tcp, port=ssh]
logpath = /var/log/secure

enabled = true
filter = apache-auth
action = iptables-allports[name=apache-auth, protocol=all]
logpath = /var/log/httpd/error_log

enabled = true
filter = vsftpd
action = iptables-multiport[name=FTP, protocol=tcp, port=ftp]
logpath = /var/log/vsftpd.log

When I “cat /var/log/asterisk/freepbx_security.log”, I get "Authentication failure for root from Possible proxy detected, forwarded headers forroot set to "

When i run "cat /var/log/fail2ban.log | grep “2019-03-01” , I see a lot of lines like “Creating new jail pbx-gui…”.

How can i regain access to the FreePBX GUI?

I replied in the other community he posted in.

You can start by disabling the firewall with the command fwconsole firewall stop which will remove all iptables rules.

Secondly, fail2ban is disabled (or is MEANT to be disabled) when firewall is running, as it will break your machine and lock you out of it.

I have a sneaking suspicion that you’ve tried to upgrade fail2ban, which has locked you out of your machine.

In the future, running the command iptables-save | pastebin will give you a URL that you can reference in a post, rather than trying to paste lots of text in.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.