FreePBX GUI does not load

Hi again,

I’ve reinstalled my asterisk w/PBX due to Bug I had. For some reason I can’t get my FreePBX GUI running, even though it seems Asterisk is fine. I followed these two guides
https://www.powerpbx.org/content/asterisk-freepbx-install-guide-debian-v9-asterisk-v14-freepbx-v14-v1
https://wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+Debian+8.8#InstallingFreePBX14onDebian8.8-InstallLegacypearrequirements

Running FreePBX shutdown…

Shutting down Asterisk Gracefully. Will forcefully kill after 30 seconds.
Press C to Cancel
Press N to shut down NOW
[============================] < 1 sec
Running FreePBX startup…
Starting Asterisk…
[============================] 1 sec
Asterisk Started
[email protected]:~# service freepbx status
● freepbx.service - Freepbx
Loaded: loaded (/etc/systemd/system/freepbx.service; enabled; vendor preset: enabled)
Active: active (exited) since Fri 2019-01-25 16:35:40 CET; 34s ago
Process: 1235 ExecStart=/usr/sbin/fwconsole start (code=exited, status=0/SUCCESS)
Main PID: 1235 (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 4915)
CGroup: /system.slice/freepbx.service

Jan 25 16:35:40 hostname fwconsole[1235]: 58800 [>---------------------------]
Jan 25 16:35:40 hostname fwconsole[1235]: 58900 [---------------->-----------]
Jan 25 16:35:40 hostname fwconsole[1235]: 59000 [---->-----------------------]
Jan 25 16:35:40 hostname fwconsole[1235]: 59100 [-------------------->-------]
Jan 25 16:35:40 hostname fwconsole[1235]: 59200 [-------->-------------------]
Jan 25 16:35:40 hostname fwconsole[1235]: 59300 [------------------------>—]
Jan 25 16:35:40 hostname fwconsole[1235]: 59400 [------------>---------------]
Jan 25 16:35:40 hostname fwconsole[1235]: Finished setting permissions
Jan 25 16:35:40 hostname fwconsole[1235]: Unable to run Pre-Asterisk hooks, because Asterisk is already running on PID 1250 and has been
Jan 25 16:35:40 hostname systemd[1]: Started Freepbx.
[email protected]:~#

This is what I see when I try to access the GUI.

<?php // License for all code of this FreePBX module can be found in the license file inside the module directory // Copyright 2013 Schmooze Com Inc. // if (file_exists(dirname(__FILE__) . '/index_custom.php')) { include_once(dirname(__FILE__) . '/index_custom.php'); } else { $basename = pathinfo($_SERVER['PHP_SELF'],PATHINFO_DIRNAME); $uri = (!empty($basename) && $basename != '/') ? $basename . '/admin' : '/admin'; header('Location: '.$uri); } I had some errors like these below, but I had them before. I was trying to run '_pear install Console_Getopt_', but it failed. Cannot adopt OID in UCD-SNMP-MIB: laLoad ::= { laEntry 3 } Cannot adopt OID in UCD-SNMP-MIB: laNames ::= { laEntry 2 } Cannot adopt OID in UCD-SNMP-MIB: laIndex ::= { laEntry 1 } Any ideas please? Thank you, Kind regards,

Does your OS have PHP installed and apache mod_php configured?

1 Like

Loaded Modules:
core_module (static)
so_module (static)
watchdog_module (static)
http_module (static)
log_config_module (static)
logio_module (static)
version_module (static)
unixd_module (static)
access_compat_module (shared)
alias_module (shared)
auth_basic_module (shared)
authn_core_module (shared)
authn_file_module (shared)
authz_core_module (shared)
authz_host_module (shared)
authz_user_module (shared)
autoindex_module (shared)
deflate_module (shared)
dir_module (shared)
env_module (shared)
filter_module (shared)
mime_module (shared)
mpm_event_module (shared)
negotiation_module (shared)
reqtimeout_module (shared)
rewrite_module (shared)
setenvif_module (shared)
status_module (shared)
[email protected]:/usr/src/freepbx#

Hm, well, it doesn’t seem to have it. Though I did install these
apt -y install wget php php-pear php-cgi php-common php-curl php-mbstring php-gd php-mysql php-gettext php-bcmath php-zip php-xml php-imap php-json php-snmp php-fpm libapache2-mod-php

How can I fix it?
Thanks!

Did you restart Apache? Something like:

service apache2 restart

I installed it with
apt-get -y install php7.0 libapache2-mod-php7.0 and restarted apache. Now I see this:

I think FreePBX wants PHP 5.6

Near the end of the guide you have to enable the php module and restart Apache, did you do that?

Why not make your life a ton easier and just use the Distro?

these I did, yes.

sed -i 's/\(^upload_max_filesize = \).*/\120M/' /etc/php5/apache2/php .ini
cp /etc/apache2/apache2 .conf /etc/apache2/apache2 .conf_orig
sed -i 's/^\(User\|Group\).*/\1 asterisk/' /etc/apache2/apache2 .conf
sed -i 's/AllowOverride None/AllowOverride All/' /etc/apache2/apache2 .conf
service apache2 restart

I don’t know really. I want to see under the hood. Understand the system better

You need to follow the guide in full and not skip parts. Right now you don’t have mysql extension for php installed.

Also please stop reporting these as issues on the bug tracker. They aren’t issues.

Ok, got it. Apologies for the bug tracker. I’m not aware of skipping any part of the guide

/usr/src/freepbx# apt-get install php5.6-mysql
Reading package lists… Done
Building dependency tree
Reading state information… Done
php5.6-mysql is already the newest version (5.6.40-1+0~20190111135530.9+stretch~1.gbp5f42c9).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

fixed it by installing php-7.2.

apt -y install wget php php-pear php-cgi php-common php-curl php-mbstring php-gd php-mysql php-gettext php-bcmath php-zip php-xml php-imap php-json php-snmp php-fpm libapache2-mod-php

sed -i ‘s/(^upload_max_filesize = )./\120M/’ /etc/php/7.2/apache2/php.ini
sed -i 's/(^upload_max_filesize = ).
/\120M/’ /etc/php/7.2/cli/php.ini

reboot

This is the latest info from fwconsole debug
[2019-Jan-25 20:24:52] [INFO] (framework/install.php:321) - Refreshing GPG Keys…Done
[2019-Jan-25 20:24:52] [UPDATE] (libraries/modulefunctions.class.php:2025) - Module: framework Updated to version 14.0.5.25
[2019-Jan-25 20:24:53] [INFO] (libraries/modulefunctions.class.php:2083) - Generating CSS…Done
[2019-Jan-25 20:26:39] [CRITICAL] (admin/bootstrap.php:260) - Connection attmempt to AMI failed
[2019-Jan-25 20:43:02] [CRITICAL] (admin/bootstrap.php:260) - Connection attmempt to AMI failed
[2019-Jan-25 20:43:18] [CRITICAL] (admin/bootstrap.php:260) - Connection attmempt to AMI failed
[2019-Jan-25 21:42:26] [CRITICAL] (admin/bootstrap.php:260) - Connection attmempt to AMI failed
[2019-Jan-25 21:42:42] [CRITICAL] (admin/bootstrap.php:260) - Connection attmempt to AMI failed
[2019-Jan-25 21:43:15] [NOTICE] (BMO/Notifications.class.php:507) - [NOTIFICATION]-[core]-[MEMLIMIT] - Memory Limit Changed (Your memory_limit, 128M, is set too low and has been increased to 256M. You may want to change this in you php.ini config file)

You’ll find many parts of FreePBX do not work with PHP 7.2

1 Like

If you are running Debian 9 then perhaps

will help you install php5.6

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.