Freepbx GUI : after Submit Changes, the "Apply" button does not appear

Since yesterday, when I do some modification in the Freepbx GUI like adding an extension or rename a trunk, I click on “Submit” button but then the “Apply” button does not appear.

I have do use the command “amportal a r” to reload the configuration.

I never see that.

Freepbx version : FreePBX
Asterisk version : (Ver. 11.23.0)

up ? anyone ?

Have you tried a different browser? It sounds like either a cache problem, or a general issue in the browser. I know that sounds simplistic, but I find that some things on the website do not render properly in Chrome, and only work in IE. Maybe there is some overlap with the HTML developers?

Yes I’ve tried this with an other browser. Same thing. This is not a cache problem.
I’ve installed FOP2 (Flash Operator Panel) the same day. But the Freepbx GUI worked during all day after installing FOP2. So I don’t know if it is in relation ?

If the ‘apply’ button doesn’t appear, something is crashing the Javascript interpreter in your browser. Open up your developer console (Push F12 in Chrome, and then select the ‘Console’ tab).

If the error isn’t immediately obvious (eg, does it mention fop2 in the error?) feel free to post it here.

Here are 2 messages I’ve in browser console. In every HTML pages form the GUI, I’ve this :

SyntaxError: expected expression, got ';'config.php:1223:11

ReferenceError: fpbx is not defined ,pbxlib.js:112:39 

Another thing I forget to tell.
For FOP2 installation, i’ve installed the php5-sqlite module for Debian.

uninstall fop module and see if that fixes your problem